2

I'm trying to setup a Debian VM to have a static network configuration. I have the following in /etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
    address x.y.z.73
    netmask 255.255.255.0
    gateway x.y.z.1

Nevertheless, when the ifup script is run, it insists on running a DHCP client, which I do not want. When running under shell debug, I can see that some variables with interesting names are never being set, and I don't see /etc/network/interfaces being read anywhere. I do, however, see /etc/netscripts/network.conf being read (never heard of that file before).

root@host:~# bash -x /sbin/ifup eth0
++ id -un
+ '[' root '!=' root ']'
.. snip ..
+ IF_AUTO=eth0
+ IPV4_DISABLE=NO
+ IPV6_DISABLE=NO
++ uname -r
+ BASE_MODPATH=/lib/modules/3.2.0-4-amd64/kernel
+ MODPATH=/lib/modules/3.2.0-4-amd64/kernel/net
++ cut -d . -f 1,2
++ uname -r
+ KERN_VERSION=3.2
...snip...
+ '[' -f /etc/netscript/network.conf ']'
+ source /etc/netscript/network.conf
+ . /etc/netscript/network.conf
++ VERBOSE=YES
...snip...
++ BACKUP_LEVELS=3
++ IF_AUTO=eth0
...snip...
+ vb echo -n 'Configuring interface:'
+ echo -n 'Configuring interface:'
+ '[' eth0 = all ']'
+ case "$RUNLVL" in
+ eval local 'IF_CHAIN_AUTO="${eth0_IF_CHAIN_AUTO:-}"'
++ local IF_CHAIN_AUTO=
+ if_up eth0
+ local ADDR
+ eval 'IPADDR=${eth0_IPADDR:-}'
++ IPADDR=
+ eval 'MASKLEN=${eth0_MASKLEN:-}'
++ MASKLEN=
+ eval 'BROADCAST=${eth0_BROADCAST:-}'
++ BROADCAST=
+ eval 'PTPADDR=${eth0_PTPADDR:-}'
++ PTPADDR=
+ eval 'IP_EXTRA_ADDRS=${eth0_IP_EXTRA_ADDRS:-}'
++ IP_EXTRA_ADDRS=
+ eval 'MTU=${eth0_MTU:-}'
... snip ....
+ qt type eth0_start
+ type eth0_start
+ qt type eth_start
+ type eth_start
+ eth_start eth0
+ '[' -x /sbin/dhclient ']'
+ qt /sbin/dhclient eth0
+ /sbin/dhclient eth0

Why are these settings being ignored ? Did I do a stupid typo in the config ? or did I forget to run some administrative command ? Has the interfaces file been obsoleted in favor of the network.conf one ?

1

You appear to maybe have installed netscript-2.4 instead of ifupdown, or worse, in addition to? You clearly have a modern install of debian, what with kernel 3.2. I'd check if you had ifupdown and install it if you don't. That should cause it to remove errant packages.

Good Luck.

|improve this answer|||||
  • THANK YOU, that was it. I didn't know what netscript was and I have no clue how it ended up on my system. Note that when I tried to remove netscript, it would fail with a circular dependency error between netscript and networking. I edited the netscript initscript by hand to kill the dependancy, and dpkg completed the operation correctly after that. – b0fh Jan 21 '14 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.