1

I apologize if this is answered, I may just not know what exactly to search for.

I am attempting to install Cacti on RHEL6 and have hit a wall trying to install these three package: php-snmp php-devel php-mbstring

At first, I just couldn't find them on the EPEL or RHN Tools repos. I ended up adding the remi repo, but once I did that, I began to get errors complaining about unresolved dependencies show below:

Error: Package: php-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit) Error: Package: php-cli-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit) Error: Package: php-cli-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libssl.so.10(libssl.so.10)(64bit) Error: Package: php-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit) Error: Package: php-devel-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit) Error: Package: php-devel-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libssl.so.10(libssl.so.10)(64bit) Error: Package: php-cli-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit) Error: Package: php-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libssl.so.10(libssl.so.10)(64bit) Error: Package: php-devel-5.4.24-1.el6.remi.x86_64 (remi)
Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)

To that, I tried to manually install the libcrypto.so.10 package, which led to errors about a conflict with an already installed package. I'm nearing the end of my patience on this as I've been messing with it for 2 days. I can't seem to find clear instructions on how to get this to work. I have a few years experience with Linux, but I've not messed with repos as everything I've ever needed was available on the general repo. Please be descriptive in any answers, assume I'm not familiar with the solution. I appreciate any help on this and feel free to ask for any other info that may be required that I've omitted.

  • Which (minor-)RHEL version are you using? And which openssl version do you have installed? – faker Jan 21 '14 at 17:13
  • RHEL 6.4 openssl.i686 1.0.0-27.el6_4.2 openssl.x86_64 1.0.0-27.el6_4.2 – Hypercoyote Jan 21 '14 at 17:41
0

You will most likely need to upgrade to RHEL 6.5 since OpenSSL 1.0.1 shipped with that update on which those remi RPMs are depending on.

0

One other piece of information that ended up solving it. Our RHEL point to a Satellite server. What I didn't know was that we didn't have the Optional Repositories enabled on there. Once we did that, and updated a few packages, I was able to install it. Such a simple fix, but for anyone else with RHEL, just know you will need to enable the RHN Optional repositories to install those packages.

0

cacti available through EPEL - FedoraProject

# yum info cacti
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Installed Packages
Name        : cacti
Arch        : noarch
Version     : 0.8.8b
Release     : 3.el6
Size        : 6.2 M
Repo        : installed
From repo   : epel
Summary     : An rrd based graphing tool
URL         : http://www.cacti.net/
License     : GPLv2+ and LGPLv2 and (MPLv1.1 or GPLv2 or LGPLv2) and (LGPLv2 or BSD)
Description : Cacti is a complete frontend to RRDTool. It stores all of the
            : necessary information to create graphs and populate them with
            : data in a MySQL database. The frontend is completely PHP
            : driven. Along with being able to maintain graphs, data
            : sources, and round robin archives in a database, Cacti also
            : handles the data gathering. There is SNMP support for those
            : used to creating traffic graphs with MRTG.

# 

you should uninstall cacti/php-5.4.x from your system, add epel repo and reinstall everything as it suppose too)

  • We didn't have Cacti on the system already, this was a new install. – Hypercoyote Jan 23 '14 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.