I must update an Intel S3420GPLC board. BIOS, BMC, FRU / SDR, the whole thing.

Everything is pretty much automated in the Intel download. You're supposed to boot to the integrated EFI shell, mount the USB disk/key, and launch the startup.nsh script included in the download.

Thing is, I tried with both a 4GB USB key and a larger 60GB USB disk, with poor results. Both have, of course, FAT32 filesystems.

When plugging them in and running map -r from the EFI shell, the key is not even listed. The disk shows up as blk0 and I can switch to it. Problem is getting to the script:

  • ls or dir commands returns "Cannot open current directory - Not found"
  • cd update returns "Target directory not found"

It doesn't look like the disk is correctly mounted either. Any pointers on commands I could try or BIOS settings that could be off?

Edit, new info:

  • I tried again with yet another hard disk, which yielded the same results than the first.
  • The USB ports / controller do not seem to be the problem, those I used all worked with a keyboard.
  • mount blk0 fs0 simply created an alias to blk0 but did not make it any more readable.

3 Answers 3


The first problem that you write in UNIX style. But the UEFI uses DOS style. So your sequence of commands:

mount blk0 aaa
aaa:            // !!! change disk in dos stile
cd EFI\debian    // use backslashes
grubx64.efi      // run bootloader without "./"

The second problem - you have nothing written about the disk partitioning system. You can`t use DOS partition system. Use GPT(GUID Partition Table). In Linux use gdisk. (fdisk does not fit).

As the partition types use EF00 for the boot disk(fat32), 0700 for the root partition (Ext4 for example)

so your drive will look like this:

gdisk -l /tmp/disk
GPT fdisk (gdisk) version 0.8.7

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /tmp/disk: 2048 sectors, 1024.0 KiB
Logical sector size: 512 bytes
Disk identifier (GUID): 21FCB27E-DBE0-47F9-9D03-811638115E24
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 2014
Partitions will be aligned on 2-sector boundaries
Total free space is 0 sectors (0 bytes)

Number  Start (sector)    End (sector)  Size       Code  Name
   1              34              53   10.0 KiB    EF00  EFI System
   2              54            2014   980.5 KiB   0700  Microsoft basic data


I had this problem with a Fedora 22 Live image on an USB stick created as per UEFI boot of USB sticks using

livecd-iso-to-disk --efi --format --reset-mbr Fedora-Live-Xfce-x86_64-22-3.iso /dev/sdX

Which gives a bootable GPT-organized disk with a VFAT partition.

Then I tried to myy a ZOTAC Nano CI320 using that stick and found myself in a EFI shell (with swiss french USB keyboard mapped to US, but thta's by the by).

The above and UEFI Shell got me out of the dead end:

UEFI shell boot: Follow the white rabbit #1 UEFI shell boot: Follow the white rabbit #2 UEFI shell boot: Follow the white rabbit #3

...and off we go!

  • My Intel Joule hangs after calling grubx64.efi in Ubuntu 16.04
    – mustafa
    Nov 14, 2017 at 18:09
  • Old post, but those screenshots showed exactly what I needed to do to boot USB stick from EFI on a Linx 12X64 tablet. +1
    – Oliver
    Apr 5, 2018 at 22:20

Media (USB Key, CD, harddrives) must be formatted as FAT (16 or 32) to be readable from EFI.

  • 5
    The question clearly states the disk was FAT32. -1 for not reading it. May 1, 2015 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .