I stumbled upon four pieces of 4GB PC2 5300F RAM from IBM (Part Number 43X5061). In my Dell Poweredge 1950 Rev 2 server there currently are two 512MB sticks, which appear to have the same specifications as my four new sticks of RAM. They all say PC2-5300F-555-11 on them.

I can't get the server to register the 4GB sticks. I know that my server supports sticks of this size, and I've tried putting them in the server paired (according to Dell documentation), unpaired, and mixed both kinds of RAM. When I put in only 4GB sticks there is no screen output, and the status display says "E2010 No Memory".

If I put in both 512MB and 4GB sticks, I do get BIOS output but the server refuses to pass POST, citing "The following dimm is not compatible with memory controller", followed by a list of the sockets with 4GB sticks in them. I've tried all possible permutations of RAMs and sockets, and I'm honestly stumped.

The only noticeable difference between the 512MB and the 4GB sticks are that the 4GB ones have an IBM part number on them, while the 512MB ones only have the hynix label. Does Dell servers not actually support IBM-labeled memory? Is my RAM broken?

Here's a picture of the two different sticks side by side: enter image description here

  • 2
    This is a hardware compatibility question related to a server. Why in the world was it closed as off-topic?!?
    – Massimo
    Jan 27 '14 at 0:53
  • @Massimo Initially, the question looked ridiculous, especially with the age of the components and the mix of vendors. The question was edited.
    – ewwhite
    Jan 27 '14 at 0:57

I think what you're running into is a ranking issue - the 512MB sticks you picture are single-rank (1Rx8) where the 4GB ones are quad-ranked (4Rx8). Are you running a current BIOS on the 1950? I'm seeing docs that imply you need at least BIOS v2.3.1 to support quad-ranked DIMMs:



  • 2
    Nice catch. That gear is so old, I forgot about the prospect of the platform changing to support increased RAM capacities.
    – ewwhite
    Jan 26 '14 at 19:00
  • The bios is Revision 1.5.1. Pretty old. I'll update the BIOS tomorrow and see if that solves the problem.
    – Arkenklo
    Jan 26 '14 at 19:43
  • 1
    Every time you consider using RAM cards that are larger than what was common at the time on Dell servers, do your homework to see if the BIOS has to be updated to support them. I've had this happen several times. Crucial says the RAM works, the server refuses to boot. Jan 26 '14 at 21:27
  • @Arkenklo If it turns out that this is true in your case, don't forget to mark this answer as correct. I too have come across this problem all too many times int he past, and it was a real pain the in a** to figure out.
    – blacklight
    Jan 27 '14 at 0:02
  • 1
    @techieb0y I finally managed to update the BIOS to the latest version, and the RAM is now regognized and usable. The ranking did seem to be the issue. Marked question as answered. Cheers everyone!
    – Arkenklo
    Jan 27 '14 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.