2

I'm following the guide for installing Passenger on Ubuntu, but when running

sudo apt-get install libapache2-mod-passenger

it tries to install Ruby 1.9.1. I already have Ruby 2.1.0 (installed via RVM). How can I make Passenger use the existing Ruby instead of installing the new one?

1

Is your rvm default set to 2.1? (e.g. rvm use --default 2.1.0 )

Try installing passenger gem (which comes with an apache & nginx installer)

gem install passenger

passenger-install-apache2-module

once it is done installing it should also give you a few lines to paste into your apache config. Source: https://www.digitalocean.com/community/articles/how-to-install-rails-apache-and-mysql-on-ubuntu-with-passenger

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.