1

today I came up with the problem that certificates cannot be verified on my openvz ubuntu containers. I checked the /etc/ssl/certs folder which is readable and seems to be ok.

However, when I try to use wget, I get the following:

$ wget https://google.com
--2014-01-29 11:05:16--  https://google.com/
Resolving google.com (google.com)... 173.194.112.194, 173.194.112.197, 173.194.112.195, ...
Connecting to google.com (google.com)|173.194.112.194|:443... connected.
ERROR: The certificate of `google.com' is not trusted.
ERROR: The certificate of `google.com' hasn't got a known issuer.
The certificate's owner does not match hostname `google.com'

I found the --no-check-certificate option which downloads at least the file, but doesn't solve the issue of accepting the certificate.

I also tried the --ca-directory=/etc/ssl/certsoption which returns the same result.

Any ideas where the problem might be, or where I can start to troubleshoot?

  • You may try to run update-ca-certificates, your certificates are probably out of date (especially if you are using "official" ubuntu appliance. – Boris Guéry Feb 5 '14 at 15:23
1

I've actually had this problem for a while myself.

It looks like the ca-certificates package is damaged in the Ubuntu container template from the OpenVZ project. I got it working by purging the package and re-installing as per this answer: https://askubuntu.com/a/428152/134756

It worked out to this:

sudo dpkg --purge --force-depends ca-certificates
sudo apt-get install ca-certificates

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.