We do not get mails from a specific provider. Their administrator send me this error message. Is it mean the problem is on our side? I'am not friendly with Exchange, how I can fix it, if I can?

Jan 27 10:42:02 lb2 postfix_smtp/smtpd[15284]: 
NOQUEUE: reject: RCPT from ketamin.websupport.sk[]: 550 5.1.1 
<myaddress@ourdomain.com>: Recipient address rejected: User unknown in relay recipient table;
from=<helpdesk@webonic.hu> to=<myaddress@ourdomain.com> proto=ESMTP helo=<localhost>
  • That's not an Exchange Server log entry, as far as I can tell. – joeqwerty Jan 29 '14 at 19:36
  • I'm guessing the exchange server is being run by the asker, and the party whose mails are being rejected use postfix. – Falcon Momot Jan 30 '14 at 0:37
  • 2
    Interesting that this closed question has over 2000 views. Perhaps the rules need to be more flexible. There are questions from users who are not admins, who want to know where to go next. They won't find the assumptions of minimal understanding - just posting an error message and saying "help". – labradort Jan 13 '15 at 15:47
  • 1
    @labradort it has over 10k view now, any progress on changing the rules? – NoNameProvided Jun 10 '16 at 13:43
  • I was referring to the rules at Stack Exchange where the question was deemed to be off-topic due to the question not showing a minimal level of understanding of the problem. I have no ability to change that judgement - I'm just a user like you. Your best thing to do is edit the question to improve the quality of it. Then maybe it would be seen as a valid question here. – labradort May 9 '18 at 16:22

The error is coming from Postfix, not Exchange. There isn't a lot of context information to debug this, but it believes the email is for the domain "ourdomain.com" which is handled by this postfix server. (relay_domain in main.cf)

It uses relay_recipient_maps (again in main.cf) to find where the mail should go within the organization's servers. The error is stating there is no user "myaddress@ourdomain.com" listed in the file referenced by the config variable relay_recipient_maps .

Hope that helps.

| improve this answer | |
  • If I understand you, you say that their server try to handle the email internally instead of send it to our server? This company is a hosting provider where our site is hosted. (and they also provide mail service to the hosted domains, but we not use this feature.) We did not get any email from their helpdesk. They have said something about that our MX record not pointing their IP address, but this is correct because we use an own mail server at the office. So maybe the problem is that they think this mail address should be on their server and handled internally? – NoNameProvided Jan 29 '14 at 18:00
  • It could be a DNS level of problem. If you run the nslookup or host command to lookup your domain, it should come back with your MX record. It is possible the webhosting system believes it is configured to handle your MX. That might be something you can disable in the postfix configuration. You'd be looking for variables mydestination, mydomain or myhostname settings within main.cf It might help to add something like relayhost in postfix and point it to the MX server for your domain. – labradort Jan 29 '14 at 18:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.