-1

Please help. I keep getting "relay host configuration problem." I think this is because I'm not setting up myhostname and mydomain correctly in main.cf. But I don't think my host name will work. I think I'm supposed to insert my machine's host name there, and it is in the format of ip-192-0-2-0.ip.secureserver.net. Can someone help me to figure out if I need to change my hostname or do something else?

Here is the problem from my maillog:

Jan 29 14:57:04 ip-192-0-2-0 postfix/smtp[27740]: warning: relayhost configuration problem
Jan 29 14:57:04 ip-192-0-2-0 postfix/smtp[27740]: 6141BB9707F: to=<example@gmail.com>, relay=none, delay=0.03, delays=0.02/0.01/0/0, dsn=4.3.5, status=deferred (Host or domain name not found. Name service error for name=secureserver.dedrelay.net type=A: Host not found)

secureserver.dedrelay.net is GoDaddy's relay mail server, which I'm trying to set up postfix to send mails through. To do this, in main.cf I have:

relayhost = [secureserver.dedrelay.net]:587

  • There certainly is no such host as secureserver.dedrelay.net. Why is that in there? – Michael Hampton Jan 29 '14 at 22:12
  • Thank you Michael. Edited question above again to explain. – Thomas Schlabomas Jan 29 '14 at 22:16
  • There's still no such host. You've gotten invalid information from GoDaddy or somewhere. Ask them to give you the correct hostname. – Michael Hampton Jan 29 '14 at 22:21
  • In my account summary, it says: "SMTP Service: Server Name: dedrelay.secureserver.net". However, when I check further back in my maillog, when I was using sendmail, I had dedrelay.where.secureserver.net. Here is a maillog snip: Nov 5 14:50:31 ip-192-0-2-0 sendmail[17665]: rA5LoVDo017665: to=example@yahoo.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30005, relay=dedrelay.where.secureserver.net. [nn.nn.nn.nn], dsn=2.0.0, stat=Sent (lxqX1m00N2RKi1N01 mail accepted for delivery) – Thomas Schlabomas Jan 29 '14 at 22:27
  • You reversed it. Did you not read the answer? – Michael Hampton Jan 29 '14 at 22:28
1

There's no such host as secureserver.dedrelay.net. You've gotten invalid information from GoDaddy or somewhere. Ask them to give you the correct hostname.

I would guess it will be dedrelay.secureserver.net and that you put it in backward. That is a valid host.

  • That was it Michael. I feel very stupid. Now it is able to find the host. However, I am still not able to connect to the host. I'm getting this now: Jan 29 15:30:11 ip-192-0-2-0 postfix/qmgr[28008]: D8B7BB97080: from=<info@example.com>, size=417, nrcpt=1 (queue active) Jan 29 15:30:35 ip-192-0-2-0 postfix/smtp[28011]: connect to dedrelay.secureserver.net[nn.nn.nn.nn]:587: Connection timed out Do you want me to accept your answer and ask a new question? – Thomas Schlabomas Jan 29 '14 at 22:39
  • At this point, since you have the correct information in there now, you should contact GoDaddy. – Michael Hampton Jan 29 '14 at 22:40
  • Ugh they are so unhelpful. But thank you I will accept your answer and do that. – Thomas Schlabomas Jan 29 '14 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.