I have a FC11 installation that I have converted to a VMware disk image to run om my VMware Server. I converted it with qemu-img, as the VMware Converter software apparently only converts Linux hosts to VMware Infrastructure servers.

The disk image boots fine (grub is loaded and boots the kernel) but it seems like the disk is not found by the kernel, and the boot process stalls. Hotplugging USB devices work (the kernel prints debug information) and I'm able to press keys (Ctrl-Alt-Delete for instance).

The VMware guest OS is set to RedHat Enterprise Linux 5 (32 bit), and I have tried both the LSI Logic, LSI Logic SAS and VMware Accelerated SCSI SCSI controllers, to no avail.

I'm able to boot an installer disk and get into rescue mode and mount the filesystem, so my question is, what do I need to do to the guest kernel / initrd image to make it recognize the virtual disk?


I booted into rescue mode, did a chroot /mnt/sysimage, brought up the network and ran

yum install kernel

which installed a new kernel. The previous kernel, was not working. Now, when rebooting the system, the disk is detected without problems and the system boots up perfctl.

Whether this worked because initrd could correctly determine the loaded kernel modules, or whether it was some other problem with the old kernel I don't know.

Another tip, remove the grub splashimage and the kernel option "rgbh" in /boot/grub/menu.lst - before I did this I had problems with nothing at all apperaring on the VMware console during startup.

  • 1
    The reason this worked is because the kernel packages build the initrd on-demand. When the initrd is built, it polls for the SCSI devices you're currently using, and includes them. In the future, the "proper" way to do this yourself would be to edit /etc/modprobe.conf, add alias scsi_hostadapter mptscsih (for LSI Logic, anyway), then mkinitrd -f /boot/initrd-<version>.img <version> and reboot. – jgoldschrafe Nov 18 '10 at 19:21

What filesystem type diod you use for / ? I do not think VMware supports ext4 yet.

  • 1
    It's ext4. However, VMware should not care what filesystem I use, and what's more, I'm fully able to access the file system from rescue mode (booting the Install CD). – Kristian Aug 21 '09 at 12:48
  • -1 This is irrelevant for a VM, and even for the host, ext4 works fine. – Jed Daniels Nov 18 '10 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.