7

Are there any BIOS settings that I need to change on a HP ProLiant DL380-G5 to get Server 2012 R2 hyper-V role working?

"Intel Virtualization Technology" is enabled, is there anything else I need to change?

Error: Hypervisor launch failed: Processor does not provide the features necessary to run the hypervisor (leaf 0x800000001, register 0x3:features needed 0x20100800, features supported 0x20000800

  • 2
    What is the problem you are having? – Michael Hampton Jan 31 '14 at 22:07
  • Probably not, that processor should have everything enabled by default to let it run. What is not working in terms of the role? From the wording of your question I assume that you are installing Server 2012 R2 and the adding the Hyper-V role, or are you actually installing the product called "Hyper-V Server 2012 R2" which is a different SKU in the Microsoft catalog. – Eurisko79 Feb 1 '14 at 4:58
  • Error: Hypervisor launch failed: Processor does not provide the features necessary to run the hypervisor (leaf 0x800000001, register 0x3:features needed 0x20100800, features supported 0x20000800) – NickC Feb 1 '14 at 18:18
11

For Hyper-V 2012: http://www.poxycat.com/2008/06/enabling-ms-hyperv-on-hp-dl380-g5.html

Go into the BIOS by pressing F9. Go to "Advanced options > Processor Options" and enable these two sub-options:
No-Excecute Memory Protection and
Intel(R) Virtualization Technology
Save with F10.

For Hyper-V 2016 you're out of luck, as the DL380 doesn't support SLAT: http://vstepic.blogspot.co.uk/2016/10/windows-server-2016-hyper-v-requirements.html

For Windows Server 2016 Hyper V role, Second Level Address Translation (SLAT) is requirement, instead recommendation as it was for Windows Server 2012 Hyper V.

|improve this answer|||||
  • Thats it, it was the No-Excecute Memory Protection which was not enabled. Thanks Mike. – NickC Feb 1 '14 at 18:19
  • Same here. Enabling No-Execute Memory Protection made it all work. – Russell Uhl May 24 '15 at 21:57

Not the answer you're looking for?Browse other questions tagged or ask your own question.