0

I have recently tried to update my Cent OS web server with YUM update which was interrupted. This caused some issues and took there server offline. See the following question for details of this: kernel-firmware is a duplicate with kernel-firmware Cent OS YUM

I have fully resolved these issues now but I am still unable to access the server and the only way of doing so is using rescue mode to mount the drive and chroot into the mount. When I ping the server IP address it just timeouts.

The server is a virtual machine at rackspace cloud. I have tried to update iptables to ensure the firewall isn't blocking connections but when trying to save with sudo service iptables save I get the following error: Opening /proc/modules: No such file or directory.

Where do I go from here to get the server back online?

  • 1
    Are you sure it's a firewall issue? Have you tried to boot the server and watch the console for any problems? – Michael Hampton Feb 1 '14 at 15:24
  • It quite possibly has nothing to do with the firewall at all. I cannot boot and watch console if it is a remote virtual machine with rackspace can I? – Matt Feb 1 '14 at 15:38
  • How are you chrooting ? Are you sure you have mounted the proc FS before chroot? example: mount -t proc none /mnt/proc Also have you checked the logs of your chrooted system? – b13n1u Feb 1 '14 at 15:46
  • [root@RESCUE-web ~]# mount /dev/xvdb1 /mnt and then [root@RESCUE-web ~]# chroot /mnt I am trying to look at the logs now but not sure which one to be looking at, boot seems fine. – Matt Feb 1 '14 at 15:48
  • 1
    It looks like your system is not booting at all. You should try to connect through the console. According to the link provided by MichaelHampton, it is an Ajax web terminal so it does not matter if you use MacOS.Windows or Linux. Please check out your rackspace control panel. – b13n1u Feb 1 '14 at 17:07
0

Having followed the helpful comments above by Michael Hampton and b13n1u I contacted Rackspace support and discovered that the /boot/grub/menu.lst was not properly formatted.

rd_NO_DM rhgb

Had to be replaced with

initrd /boot/initramfs-2.6.32-279.22.1.el6.x86_64.img

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.