I am trying to install opendkim. For that, I used rpm to install epel, then did yum install opendkim. However, I get the following dependency errors:

Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel) Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)

Error: Package: libopendkim-2.9.0-2.el6.x86_64 (epel) Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel) Requires: libssl.so.10(libssl.so.10)(64bit)

Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel) Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

As far as I can tell, this is because I'm running openssl 1.0.0, and it's looking for 1.0.1. I feel like I should update openssl, but I'm not sure how, and I'm a little nervous to do that. Can anyone tell me if this is in fact what I need to do? This may be a duplicate question but I don't understand the answer: https://serverfault.com/questions/571093/why-yum-update-php-doesnt-have-required-dependencies-centos-6-missing-libcrypt

marked as duplicate by Michael Hampton Feb 3 '14 at 17:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


You need to update your system.

RHEL (and CentOS) switched from OpenSSL 1.0.0 to 1.0.1 during the 6.4-6.5 cycle in order to resolve a years-long issue. As a result any programs which use OpenSSL had to be rebuilt for 6.5.

Since EPEL only tracks the latest point release, and its software is only guaranteed to run on the latest point release, you need to update to 6.5.

A simple yum --disableexcludes=all upgrade should take care of it.

  • Thanks Michael! Before I try this -- will it work even though I'm currently running CentOS 6.4? – Thomas Schlabomas Feb 3 '14 at 3:23
  • That's the whole point! – Michael Hampton Feb 3 '14 at 3:24
  • OK, sorry, misunderstood and wanted to be on the safe side. I just ran yum --disableexcludes=all upgrade and tried again, but I get the same list of dependency errors. Also when I check, I notice that I still have CentOS 6.4. – Thomas Schlabomas Feb 3 '14 at 3:31
  • Something is terribly wrong with your system. Are you sure you are actually using CentOS and that it hasn't been tampered with or reconfigured? In particular check the /etc/yum.repos.d/CentOS-Base.repo file and make sure it hasn't been redirected to something other than official CentOS repositories. – Michael Hampton Feb 3 '14 at 3:32
  • Ugh. That sounds bad. I'm sure I'm running CentOs, yes. I'm the only one with access, unless I've been hacked, and I've never reconfigured it. When I ran your command above, then checked to see what version of CentOs I had, it still said "CentOS release 6.4 (Final)" – Thomas Schlabomas Feb 3 '14 at 3:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.