We've got a build server (Windows Server 2008 SP2, 64-bit) which has one NIC and two IP addresses registered to that NIC ( and The build server is registering two identical Host (A) records for itself in our DNS server:

  • buildserver.example.com =>
  • buildserver.example.com =>

I know in the "Advanced TCP/IP Settings" window for the build server's NIC, under the "DNS" tab, there is a check box labeled "Register this connection's addresses in DNS". I only want ONE of the IP addresses (ending in .30) to be registered in DNS not both of them. Can that be done?

My best guess is to disable the "Register this connection's addresses in DNS" and manually add the Host (A) record to our DNS server.

Thanks for any help!

  • 3
    I think you're probably on the money with the removal of "Register this connection" and manually adding the host. From my understanding, that setting will apply at the NIC level meaning all IPs bound to that NIC will be affected and added to DNS.
    – Marcus
    Aug 21, 2009 at 19:10
  • Thanks Marcus, I ended up doing just that - disabling "Register this connection" and manually entered the Host (A) records in the DNS server.
    – Brad B.
    Aug 21, 2009 at 22:22
  • 2
    Marcus, Put this comment into the answer box. So it can be upvoted and accepted. Aug 22, 2009 at 12:18

3 Answers 3


I had same problem with server that hosts multiple IPs on single network card. On name resolving on other machines I was getting random one of those IPs. Since I don't control DNS server (and it was Friday late at night) I removed all IPs except one, check "Register this connection's address in DNS, verified on other machines that DNS lookup returns the address that I wanted. Then I cleared "Register this..." and added other IP addresses. So far it works.

Update: But after first reboot of the server it again registered other (wrong) IP address

Update: There is a hotfix for Server 2008 to prevent registration of multiple IP addresses. After the hotfix create new IP address using:

Netsh int ipv4 add address < Interface Name > < ip address > skipassource=true

  • That will only be a temporary fix. If the one address is not re-registered, eventually the savaging will remove the DNS entry (assuming it is turned on).
    – Doug Luxem
    Aug 28, 2009 at 20:29

If you're on a virtual environment it's pretty normal to just add a second NIC to separate your DNS registrations.

netsh int ipv4 add address <interface_name> <ip_address> skipassource=true

is not successful, as it will not add in locally but in DNS server it will get added and make an host A entry.

So the best option is to disable the "Register this connection's addresses in DNS" and manually add the Host (A) record to our DNS server. This really works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.