I am trying to convert a windows server 2008 R2 using vCenter. First, i would like to note i already successfully converted a windows server 2008 using the same process. The process fails for this specific server.

Im using the VMWare vCenter Converter Standalone v5.5.0 and i'm trying to convert a physical windows 2008 server to a virtual one.

After digging the internet i found several solutions:

Adding the user to the local administrators group on both the source and destination servers Running the software as an administrator (right click > run as an administrator)

I have tried both options, yet i still get "permission to perform this operation was denied". I am running vCenter from a windows 7 computer which is part of the domain and the account is part of the local administrators group. Same account is part of the windows server Domain Admins group and local Administrators group.

Any ideas on how i can bypass this error ? Any help is greatly appreciated. Thanks in advance!

  • First off, what software are you using to run the conversion? The vCenter Converter Standalone client or some third party application? – Mike Naylor Feb 5 '14 at 17:46
  • Im using the VMWare vCenter Converter Standalone v5.5.0 – Sebastian Feb 5 '14 at 18:02
  • Is this a Physical to Virtual or other type of conversion? – Mike Naylor Feb 5 '14 at 18:04
  • Physical to virtual conversion. – Sebastian Feb 5 '14 at 18:09
  • When setting up the conversion are you able to view the details of the 'source' physical machine? Also does it get past the point of installing the files and services on the source? If so, tell it to not remove the files when completed and try changing those services to run as the domain administrator on that physical machine, restarting the services and attempting the conversion again. – Mike Naylor Feb 5 '14 at 18:12

Check the logs in c:\users\all users\vmware\vmware converter standalone\logs\worker.xml (this might not be the exact string but should get you there).

I also tried both of the above fixes without success. My worker log showed that it was still not running the process as a full administrator (even with right click-> run as administrator). "UAC is enabled! blah blah blah" in the log

I got it to work by turning off UAC on the Win7 host and rebooting. http://windows.microsoft.com/en-us/windows/turn-user-account-control-on-off#1TC=windows-7

After reboot I still right-clicked -> run as administrator for vConverter but I was finally able to P2V without issue.

Ah, just saw the comments vs answer. Yes. Running as the local "Administrator" account would probably work as well since it treats UAC different for Administrator. I do not know the local "Administrator" account password and would not be authorized to change it… but temporarily disabling UAC does work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.