I have a project under SVN control. SVN and repository reside on a Linux Debian 6 server. On the server I have a working copy as well (for Apache to show the website for test purposes).

The checkout on the server (svn co /path/to/projectworkingcopy file:///path/to/repositories/project -m "First") worked like a charm with no problems at all.

On TortoiseSVN, the checkout starts and imports some files, then compains throwing an error on a filename; the error is like this:

'foldername/file_name_123_abc.jpg' is not valid as filename in directory 'C:\path\to\working\copy\project\dira\dirb'

And then it says Completed! without any other file being imported.

I searched on the internet but no solutions fit my problem. The folder that Tortoise can't checkout ha NO spaces, there are no spaces on filename, there are no files with dots (.) at the end of their name.

And, again: on the server the checkout had NO problems at all. That file exists on the server's working copy.

Update: I tried to checkout exluding the folder 'foldername' and is going well. Anyhow there are no spaces on the complete path to foldername, so I really can't understand why I get this error. And, I obviously NEED that folder!

Update: real path of one of the files causing errors:


What can I do? Thank you.

  • doublecheck for spaces anywhere in path :) – Dusan Bajic Feb 7 '14 at 9:58
  • @dusan.bajic there are no spaces AT ALL on the path.. That's the why I cannot understand why I get this error – tobia.zanarella Feb 7 '14 at 10:19
  • try another SVN client, to isolate problem between Tortoise and Windows itself – Dusan Bajic Feb 7 '14 at 10:38
  • 1. The question has to be asked at StackOverflow. 2. Show us the exact REAL path to the file. Some characters in the path are considered invalid on Windows while Linux accepts them. I guess we can narrow this down if we know the affected path. – bahrep Feb 7 '14 at 15:06

It might be caused by the case insensitive filesystem in Windows (NTFS/FAT)


svn ls file:///path/to/repositories/project/site/public/www/images/auto/audi/|grep -i '120045_audi_A3__5858_t45e444.jpg'

And be sure it only outputs a single line.

  • 1
    Had a similar strange thing, where the directory name (on the server) ended with a blank. Valid for Linux, not for Windows. – mliebelt Jun 7 '16 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.