0

I have an Ubuntu 12.04 machine with 3 disks in RAID5, and the RAID controller is on the motherboard. After almost a year of flawless use, it seems that one disk had a failure. Every time I restarted the machine, it said that there was a partition with damaged filesystem and a fsck was forced to run. I tried to recover it with a LiveCD using the fsck command on the unmounted disks, with no results.

At one point, grub gave me the following:

error> unknown filesystem

On the LiveCD, the lsblk command gives this:

$ sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL
NAME                                 FSTYPE            SIZE MOUNTPOINT LABEL
loop0                                squashfs        651.6M /rofs      
sda                                  isw_raid_member 596.2G            
└─isw_cifbdbija_RAID-ABE (dm-0)                      1.2T            
  ├─isw_cifbdbija_RAID-ABE1 (dm-1) vfat               94M            
  ├─isw_cifbdbija_RAID-ABE2 (dm-2)                   1.2T            
  └─isw_cifbdbija_RAID-ABE3 (dm-3) swap              3.7G            
sdb                                  isw_raid_member 596.2G            
└─isw_cifbdbija_RAID-ABE (dm-0)                      1.2T            
  ├─isw_cifbdbija_RAID-ABE1 (dm-1) vfat               94M            
  ├─isw_cifbdbija_RAID-ABE2 (dm-2)                   1.2T            
  └─isw_cifbdbija_RAID-ABE3 (dm-3) swap              3.7G            
sdc                                  isw_raid_member 596.2G            
└─isw_cifbdbija_RAID-ABE (dm-0)                      1.2T            
  ├─isw_cifbdbija_RAID-ABE1 (dm-1) vfat               94M            
  ├─isw_cifbdbija_RAID-ABE2 (dm-2)                   1.2T            
  └─isw_cifbdbija_RAID-ABE3 (dm-3) swap              3.7G            
sdd                                                    3.7G            
└─sdd1                               vfat              3.7G /cdrom     MYLINUXLIVE

Please help me, I need to recover the content of these disks. It would be very nice to recover the system, as well, instead of formatting and re-installing.

UPDATE: This might help, as I'm trying to mount the 2nd partition of the RAID. I tried to

$ sudo mount -t vfat /dev/mapper/isw_cifbdbija_RAID-ABE2 /mnt

and I got

mount: wrong fs type, bad option, bad superblock on /dev/mapper/isw_cifbdbija_RAID-ABE2
  • 2
    RAID controller is on the motherboard Sounds like fakeRAID, which is a crime against humanity. Ditch the fakeRAID and use either hardware-RAID (with a proper RAID card) or software RAID. All fakeRAID does is combine the drawbacks of software-RAID and the drawbacks of hardware-RAID into a product that will screw you over and make you hate your life at the first possible opportunity. – HopelessN00b Feb 10 '14 at 14:48
  • 1
    To add to what @HopelessN00b has to say, don't use RAID5 with large disks it's a crime against data and don't continue to work with out backups it's a crime against sysadmining and the mark of an amateur. – user9517 supports GoFundMonica Feb 10 '14 at 14:52
  • Of course I'm going to learn a lot from this incident. But now I'm looking for a solution... Is there any way to mount the partition on the LiveCD and extract the data? It shouldn't be that hard, I tried to mount /dev/sda /mnt/mydisk, but all I get is: mount: unknown filesystem type 'isw_raid_member' – Alessandro Cappello Feb 10 '14 at 15:06
  • No...you can't mount a RAID member like that. You'd need to rebuild the array by replacing the failed disk. – Nathan C Feb 10 '14 at 15:17
  • But how can I know which disk have the problem? – Alessandro Cappello Feb 10 '14 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.