4

in my php coding i have following line which uses by SWIFT MAILER Class

if(!stream_socket_enable_crypto($this->smtp_conn, true, STREAM_CRYPTO_METHOD_TLS_CLIENT)) {

  return false;

}

however rarely (not always) i get following php error

stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

i am not sure where the problem is or should i ignore this as this happens only once in a while

1
  • I'm using PHP Version 5.3.6-8ubuntu0ppa5~lucid1 with the PHPMailer class and I see the same error.
    – Citricguy
    Feb 21 '14 at 0:55
1

I had the same error.

stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

It was caused by incorrect SMTP settings. I had:

$transport = Swift_SmtpTransport::newInstance('mail.myserver.com', 465, 'tls');

and as soon as I corrected it to

$transport = Swift_SmtpTransport::newInstance('mail.myserver.com', 465, 'ssl');

it worked normally. Quite a non-intuitive error message but I got there in the end.

1
  • i change SMTPSecure tls to ssl, and Port 586 to 465, and working now.
    – matasoy
    Oct 4 at 14:08
0

In your php.ini search for line

; extension=php_openssl.dll

and remove ; so it becomes:

extension=php_openssl.dll

Then save & restart & enjoy.

0

Typically routines:SSL3_GET_RECORD:wrong version number is code for the server not using SSL/TLS at all.

So, make sure to check that first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.