I use for remote desktop connection script rdesktop. On some machines I get common error without any value.

What can I do after "Connection reset by peer" error?

4 Answers 4



From time to time I forget this setting. The vast majority of it means "Turn off Remote Desktop with NLA".

Set on target "Microsoft Windows (WIN)"

  1. run SystemPropertiesRemote.exe
  2. deselect "Allow connections only from computers running Remote Desktop with NLA"
  3. try to connect from linux client


Thanks to Maccu Falchi


  • 1
    Worked for me while trying to connect from Linux Mint client to Windows 2012 R2 Server. Mar 30, 2014 at 3:57
  • Tried this on a windows 10 host. It does not work, at least at the time being. The freerdp-x11 works.
    – minghua
    Jan 4, 2018 at 8:49
  • @minghua In my last experience with new instal "#win10 on aws" this was default disabled.
    – Bruno
    Jan 4, 2018 at 13:49

If you don't have control over the server you are trying to connect to (or having a bit of chicken/egg situation), then use FreeRDP which supports NLA.

On Debian run

sudo apt-get install xfreerdp-x11

On Ubuntu run

sudo apt-get install freerdp-x11

On Fedora 22 run

sudo dnf install -y freerdp

Check here for more details

  • 1
    I needed to do sudo apt-get install freerdp-x11 on ubuntu 14.04
    – Chris Snow
    Jul 6, 2015 at 10:53
  • 1
    Note, the executable is called xfreerdp. Sep 26, 2017 at 16:06

I've been dealing with the same issue. The cursor is there - you just can't see it.

So, instead of grabbing some cursors from Windows and hacking your way around this - just use the "-C" flag to use your current custom color map.

e.g. rdesktop -C -u -d xx.xx.xx.xx

This fixed it just fine for me, and needed no other workarounds.

  • Thank you for valuable info about colors - but you know that article is about connection right? :-)
    – Bruno
    Aug 19, 2016 at 22:51
  • This worked. However, -u -d appears to mean "log in as user -d". Perhaps -d should be replaced with username. May 31, 2017 at 0:50
  • This does not work on a windows 10 host at this moment. The freerdp does work.
    – minghua
    Jan 4, 2018 at 8:53

Well, in my case it was not the NLA authentication setting on the server. What has changed -- the operating system on the server was re-installed and so the fingerprint (or the host key) has changed. The freerdp on linux stored the previous fingerprint in a file under your home folder ~/.freerdp/known_hosts.

The error comes from the fact that the server IP address is the same but the fingerprints don't match.

The solution is to clear or delete the ~/.freerdp/known_hosts file on the linux guest.

  • I haven't encountered this error but good to know.
    – minghua
    Jan 4, 2018 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .