3

I'm trying to install mongodb driver with pecl and for this i need phpize (php-devel). Does anyone know how can i resolve this issue or there is another way to install php-mongodb driver?

I try as suggested : using --skip-broken to work around the problem and running: rpm -Va --nofiles --nodigest Didn't work either

sudo yum install php-devel
Loaded plugins: rhnplugin
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-devel.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: php(x86-64) = 5.3.3-22.el6 for package: php-devel-5.3.3-22.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-devel-5.3.3-22.el6.x86_64 (shared-rhel-x86_64-server-optional-6)
           Requires: php(x86-64) = 5.3.3-22.el6
           Installed: php-5.3.3-27.el6_5.x86_64 (@rhel-x86_64-server-6)
               php(x86-64) = 5.3.3-27.el6_5
           Available: php-5.3.2-6.el6.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.2-6.el6
           Available: php-5.3.2-6.el6_0.1.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.2-6.el6_0.1
           Available: php-5.3.3-3.el6.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-3.el6
           Available: php-5.3.3-3.el6_1.3.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-3.el6_1.3
           Available: php-5.3.3-3.el6_2.5.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-3.el6_2.5
           Available: php-5.3.3-3.el6_2.6.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-3.el6_2.6
           Available: php-5.3.3-3.el6_2.8.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-3.el6_2.8
           Available: php-5.3.3-14.el6_3.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-14.el6_3
           Available: php-5.3.3-22.el6.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-22.el6
           Available: php-5.3.3-23.el6_4.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-23.el6_4
           Available: php-5.3.3-26.el6.x86_64 (cust_drv-rhel-x86_64-server-6-default-nonprod)
               php(x86-64) = 5.3.3-26.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

i have manage to install php-devel by download the rpm and installing it.

The result of yum list installed | grep php :

php.x86_64                      5.3.3-27.el6_5     @cust_drv-rhel-x86_64-server-6-default-nonprod
php-cli.x86_64                  5.3.3-27.el6_5     @rhel-x86_64-server-6        
php-common.x86_64               5.3.3-27.el6_5     @rhel-x86_64-server-6        
php-devel.x86_64                5.3.3-27.el6_5     installed                    
php-gd.x86_64                   5.3.3-27.el6_5     @rhel-x86_64-server-6        
php-mbstring.x86_64             5.3.3-27.el6_5     @rhel-x86_64-server-optional-6
php-mcrypt.x86_64               5.3.3-1.el6        @epel-rhel-x86_64-server-6   
php-mysql.x86_64                5.3.3-27.el6_5     @rhel-x86_64-server-6        
php-pdo.x86_64                  5.3.3-27.el6_5     @rhel-x86_64-server-6        
php-pear.noarch                 1:1.9.4-4.el6      @cust_drv-rhel-x86_64-server-6-default-nonprod
php-xml.x86_64                  5.3.3-27.el6_5     @rhel-x86_64-server-6

result of pecl install mongo

downloading mongo-1.4.5.tgz ...
Starting to download mongo-1.4.5.tgz (141,417 bytes)
..............................done: 141,417 bytes
84 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
shtool at '/var/tmp/mongo/build/shtool' does not exist or is not executable.
Make sure that the file exists and is executable and then rerun this script.

ERROR: `phpize' failed

result of phpize :

 phpize
Cannot find config.m4. 
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module
3
  • Could you show output of the # yum list installed | grep php
    – ALex_hha
    Feb 13, 2014 at 15:33
  • Add result of list yum list installed. my final goal is to install mongo-db php driver. didn't know it will be so hard. Feb 15, 2014 at 11:50
  • This package is already in EPEL, named php-pecl-mongo. Why are you trying to compile it? Feb 15, 2014 at 12:26

1 Answer 1

1

Your problem is here:

Error: Package: php-devel-5.3.3-22.el6.x86_64 (shared-rhel-x86_64-server-optional-6)
           Requires: php(x86-64) = 5.3.3-22.el6
           Installed: php-5.3.3-27.el6_5.x86_64 (@rhel-x86_64-server-6)

Your version of php is higher than the available php-devel. Either downgrade php to 5.3.3-22 or find a channel/repo that offers you the later version of php-devel.

1
  • pecl install mongo still not working for me. even that i installed php-devel from fedora repo. I manually installed the php-mongo-driver and its working now. Feb 15, 2014 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .