I can't figure out how to properly configure these Samba shares. Really I can't understand what's wrong.

I read many many articles here, on AskUbuntu forum, on LinuxQuestions and other forums and website. I really tried EVERY possible combination of config parameters.
I first tried with the proper ones - the ones I assumed they should have worked - then I step-by-step tried changing all parameters until now: I really can't understand how to set the params to make it work. Please help me!

How it's intended to work

  • 1 public (accessible from everyone who connects to the server, Read/Write), 1 protected (accessible only with defined username and password, Read/Write);
  • Some users must have access to both shares (the defined ones), some other only to the public one;
  • Public share name: DSMPubblica;
  • Private share name: DSMUfficio;
  • From Windows, I should be able to configure DSMPubblica on, ie, letter Y: and access it straightly AND THEN I should be able to configure DSMUfficio in letter Z: and be prompted with username and password window.

Additional efforts and log lines

I tried something more. I deleted from my config the two shares and created a new one, public, called "Public". When I try to connect, Windows says it's impossible to connect.

On the log I can see:

  • smb_pwd_check_ntlmv1: incorrect password length (62) => ??? I DON'T WANT the user to specify a password and Windows doesn't even ask me for one...
  • process_usershare_file: stat of /var/lib/samba/usershares/dsmufficio failed. Permission denied => ??? What is /var/lib/samba/usershares/dsmufficio? It doesn't exists in my Linux server and it's not specified anywhere in the config file (not even "usershares").

What happens

Everything happens with Windows 7 and Windows 8.1.

  • I try to connect a new network share;
  • I select the letter (Y:) for DSMPubblica;
  • I write the server address (\\DSMPubblica);
  • I check "Connect again at restart" and don't check "Connect with different credentials" (the check on credentials is indifferent - same behaviour with or without check);
  • I am prompted with authentication window!
  • If I click OK without entering any username, Windows won't let me continue: he WANTS a username AND a password.
  • If I give him my username and password set for DSMUfficio, then I'm able to connect;
  • Same for DSMUfficio, but with this one it's OK for Windows to ask me for authentication;
  • If I check "save authentication credentials", at restart it asks me everything again.

My Config

The shares

    delete readonly = yes
    writeable = yes
    path = /var/dsm/ufficio
    write list = tzanarella,jcangini,dlazzarato,mcazzoli,sgiombetti
    force group = dsm
    revalidate = yes
    comment = DSM share locale privata - solo autorizzati
    valid users = tzanarella,jcangini,dlazzarato,mcazzoli,sgiombetti
    create mode = 770
    directory mode = 770

    guest ok = yes
    guest account = 
    writeable = yes
    delete readonly = yes
    path = /var/dsm/pubblica
    force directory mode = 777
    force create mode = 777
    comment = DSM share locale pubblica - senza restrizioni di accesso
    create mode = 777
    public = yes
    browsable = yes
    directory mode = 777

Note that DSMPubblica configuration has changed many many MANY times in order to try to make it work properly. I really tried every single combination... Nothing worked. If you need more tests, information, specifications, just ask and let me know. Thank you.

Whole configuration

# Sample configuration file for the Samba suite for Debian GNU/Linux.
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which 
# are not shown in this example
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic 
# errors. 
# A well-established practice is to name the original file
# "smb.conf.master" and create the "real" config file with
# testparm -s smb.conf.master >smb.conf
# This minimizes the size of the really used smb.conf file
# which, according to the Samba Team, impacts performance
# However, use this with caution if your smb.conf file contains nested
# "include" statements. See Debian bug #483187 for a case
# where using a master file is not a good idea.

#======================= Global Settings =======================


## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = DSM

# server string is the equivalent of the NT Description field
   server string = %h server

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes

#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d

####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
#   security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
   encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
   passdb backend = tdbsam

   obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
;   domain logons = yes
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the 
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
#   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
#   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;   winbind enum groups = yes
;   winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

#======================= Share Definitions =======================

   comment = Home Directories
   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# The following parameter makes sure that only "username" can connect
# to \\server\username
# This might need tweaking when using external authentication schemes
   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

# A sample share for sharing your CD-ROM with others.
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#   cdrom share is accesed. For this to work /etc/fstab must contain
#   an entry like this:
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
# The CD-ROM gets unmounted automatically after the connection to the
# If you don't want to use auto-mounting/unmounting make sure the CD
#   is mounted on /cdrom
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom

    delete readonly = yes
    writeable = yes
    path = /var/dsm/ufficio
    write list = tzanarella,jcangini,dlazzarato,mcazzoli,sgiombetti
    force group = dsm
    revalidate = yes
    comment = DSM share locale privata - solo autorizzati
    valid users = tzanarella,jcangini,dlazzarato,mcazzoli,sgiombetti
    create mode = 770
    directory mode = 770

    guest ok = yes
    guest account = 
    writeable = yes
    delete readonly = yes
    path = /var/dsm/pubblica
    force directory mode = 777
    force create mode = 777
    comment = DSM share locale pubblica - senza restrizioni di accesso
    create mode = 777
    public = yes
    browsable = yes
    directory mode = 777
  • I had the problem that the windows username was identical to the unix username on the machine running samba. Samba then imported the unix username and therefor always asked for the password. An easy fix was to remove the samba username via pdbedit -x -u <username>. Also see superuser.com/questions/635782/… - the rest was taken care of via map to guest = bad user in the smb.conf
    – x29a
    Sep 24, 2014 at 9:28
  • @x29a I also us the same username and password for Windows, Ubuntu, and Samba. The strange thing is that I can't connect with windows systems A, but it works without a problem connecting with windows system B.
    – MeSo2
    Jun 12, 2020 at 4:36

11 Answers 11


This was the key option to set to resolve this issue:

    map to guest = bad user
  • 8
    You need to explain what this does, not just post two lines of config file with no context
    – endolith
    Mar 18, 2021 at 2:35

I ran into the same issue (Windows kept rejecting the pi's password) until I got a tip from this YouTube video. Basically I had to run the command:

sudo smbpasswd -a pi

to create the pi samba user. On the Windows, I just use RASPBERRYPI\pi as the user, type in the password and it works.


This is the config that (finally) worked here. I can access a linux server from Windows without asking for a user/password:

workgroup = MYGROUP
server string = Samba Server %v
netbios name = debian
security = user
map to guest = bad user
dns proxy = no
#============= Share Definitions =================
force user = adriano
path = /home/adriano
browsable =yes
writable = yes
guest ok = yes
read only = no
  • 2
    This disables any security. Guest access with write permissions. force user has no effect. Jul 3, 2015 at 7:42

2017, Windows 7 with Ubuntu 17

this config is when you don't need security or password prompt , so it's for your internal private net or for your virtual pc ( virtualbox, vmware, etc).

Example with user 'david'

in ubuntu

sudo apt install samba

edit config

sudo nano /etc/samba/smb.conf

my pc in windows had the workgroup: WORKGROUP so i did not change the section global, just added this block:

[Home Share]
comment = Home Public Folder
path = /home/david/projects
writable = yes
force user = david
public = no
browsable = yes

you need in ubuntu add to user to samba, creating a password:

sudo smbpasswd -a david

restart service

sudo systemctl restart smbd

Anybody struggling with this in 2020, please try adding to your [global]

min protocol = NT1

If you are connecting to samba server an outdated OS or a device, eg. media player.

  • 2
    While it might work, setting the minimum protocol version to NT1 means enabling SMB1. This should be avoided at all costs due to numerous exploits. Don't do it!
    – real_paul
    Feb 16, 2021 at 10:26
  • I have a media player that only does SMB1 and I will not throw it away and there is no firmware upgrade. Feb 17, 2021 at 17:19
  • 1
    I understand the wish to keep old working hardware in use but the security ramifications are severe and you should completely isolate shares with SMB1 from the rest of the network and the internet. At this point you might as well dump everything on an external drive and directly attach it to the client.
    – real_paul
    Feb 19, 2021 at 14:23
  • 1
    @real_paul I appreciate the sentiment, but not everyone needs security. I don't have SMB1 enabled, but my samba shares are not open to the internet and if someone is on my LAN that someone is someone I trust because it is me. Tolik is likely in the same scenario.
    – Demonblack
    Mar 25, 2021 at 10:04

set security type to share.

security = share

in your public share add:

public = yes

more info can been found here Samba servertype info

  • Already tried. Nothing worked. Feb 18, 2014 at 8:21
  • "security = share" is not implemented anymore. It was already deprecated 2012
    – Paul G.
    Nov 20, 2021 at 19:07

Had a similar issue...found that Cluster AD Computer Account password had expired and add to rejoin the domain to get it working.

Came across this article which makes sense. https://access.redhat.com/discussions/1283873

  • could you expand your answer a little to provide some context/info about the link you posted (and/or the solution that link suggests). Per serverfault.com/help/how-to-answer, it helps others if you quote the most relevant part of the content you link to. Mar 21, 2017 at 7:26

Forgive my bad English. ** That's for a local network, not tested on domain environmental. I know that is a old ask, but I'll left my contribution.

First of all, read this article: https://www.tecmint.com/install-samba4-on-centos-7-for-file-sharing-on-windows/

This article contains a lot of important information.

Things that you should pay attention:

  • Groups/Users Permissions
  • Folders Permissions
  • SELinux
  • Firewall

If you can, read this article too: https://www.alura.com.br/artigos/compartilhando-arquivos-com-o-samba

**I know that's in portuguese, but maybe ut could help you.

Now, thats is the way I maked it work on my environmental:

Installing samba:

$ yum install samba samba-client samba common -y

Creating a shared public folder:

$ mkdir -p /srv/samba/public $ chmod -R 0775 /srv/samba/public $ chown -R nobody:nobody /srv/samba/public

#SELINUX: $ chcon -t samba_share_t /srv/samba/anonymous

Secure folder:

$ mkdir -p /srv/samba/IT_Folder $ chmod -R 0770 /srv/samba/IT_Folder $ chown -R root:smbgrp /srv/samba/IT_Folder

#SELinux: $ chcon -t samba_share_t /srv/samba/IT_Folder

#Adding a Samba user for test $smbpasswd -a IT_user **In my case, the folder "IT_Folder" belongs to IT Group. So the IT_user is added on IT Group and have the permission to write, read and execute on IT_Folder.

#If you want to remove a user on Samba $smbpasswd -x user_name

#Setting up Iptables ports: iptables -A INPUT -p udp --dport 137 -j ACCEPT iptables -A INPUT -p udp --dport 138 -j ACCEPT iptables -A INPUT -p tcp --dport 139 -j ACCEPT iptables -A INPUT -p tcp --dport 445 -j ACCEPT

#Enable and Start the service $systemctl enable smb.service $systemctl enable nmb.service $systemctl restart smb.service $ssystemctl restart nmb.service


[root@firewall samba]# vi /etc/samba/smb.conf See smb.conf.example for a more detailed config file or read the smb.conf manpage. Run 'testparm' to verify the config is correct after you modified it.

[global] workgroup = WORKGROUP netbios name = centos security = user

[public] comment = "Public" path = /home/samba/public browsable = yes writable = yes guest ok = yes read only = no force user = nobody

[IT_Folder] comment = "IT_Folder" path = /home/samba/IT_Folder browsable = yes writable = yes read only = no

~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ "/etc/samba/smb.conf" 36L, 658C

******I tested this shared folder on windows environmental, but I had a lot of issues with user's login. Windows have a "cache authentication", so if you are testing and find this issues you can try this:

[1]On CMD.exe type this command: $ Net Use * /delete

  • If you have connections Should appear a message like: You have these remote connections:


Continuing will cancel the connections.

Do you want to continue this operation? (Y/N) [N]: y The command completed successfully.

[2] Go to Control Panel look for "Credential Manager", and then "Windows Credentials". Should appear your login of shared folder. Delete it.

[3] Finally go to "services.msc"[type this on "Run"] look for "Workstation" service, right click on it and Restart.

Now you can be allowed to inside in shared folder with another users login.


I had a line in my public share section: valid users = public

Even though I had "guest ok = yes", the server still required a login, until I removed this. I removed the line and restarted the service, and I can now access with no login prompt.


Open Terminal and type the following commands:

sudo smbpasswd –a USERNAME

Replace USERNAME with your own user name.

thats it. Fixed

  • it is a duplicate of the already posted answer even it answer the question correctly
    – djdomi
    May 28, 2022 at 15:56

I faced the same issue on Windows 11 while Windows 10 and below were working fine and were not asking for any password. I had to use the sambauser name in the username field and left the password blank.

Type user name as ./<samba username>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.