I have a VM which I've created on a host using the following settings: http://pastebin.com/raw.php?i=sevF5V7Z

It has been up and running smoothly for months but recently the VM lost connection with the outside world. When this happened the following was logged in /var/log/messages:

23:54:14.260088+02:00 foobar kernel: [11347792.392529] e1000 0000:00:03.0 eth0: Reset adapter

After that the following is logged every 8 minutes:

INFO: task kworker/0:2:15934 blocked for more than 480 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
kworker/0:2     D ffff88029fc132c0     0 15934      2 0x00000000
 ffff8800d3373d20 0000000000000046 ffff8800d3370740 ffff8800d3373fd8
 ffff8800d3373fd8 ffff8800d3373fd8 ffff8801175560c0 ffff8800d3370740
 ffff88029fc132c0 ffff8800d3372000 ffff8800d3370740 00000000ffffffff
Call Trace:
 [<ffffffff81596bf2>] schedule_preempt_disabled+0x22/0x30
 [<ffffffff815957dd>] __mutex_lock_slowpath+0xdd/0x170
 [<ffffffff815951fa>] mutex_lock+0x1a/0x40
 [<ffffffffa00f3f0e>] e1000_watchdog+0x7e/0x560 [e1000]
 [<ffffffff810616ab>] process_one_work+0x12b/0x4d0
 [<ffffffff81062f1d>] worker_thread+0x15d/0x460
 [<ffffffff810681c3>] kthread+0xb3/0xc0
 [<ffffffff8159eafc>] ret_from_fork+0x7c/0xb0

The VM was not reachable from the outside world (even to ping) and I had to restart it from the host. All other services though where still running.

The only other cases of a eth0: Reset adapter log during all those months happened on the 3 last days in random hours. In all those 3 cases the network was not interupted because it seems that the "Reset adapter" happened successfully:

2014-01-23T14:08:57.951062+02:00 foobar kernel: [11053476.083094] e1000 0000:00:03.0 eth0: Reset adapter
2014-01-23T14:08:58.042241+02:00 foobar kernel: [11053476.174267] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
2014-01-25T19:03:46.588071+02:00 foobar kernel: [11243964.720101] e1000 0000:00:03.0 eth0: Reset adapter
2014-01-25T19:03:46.658094+02:00 foobar kernel: [11243964.790501] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
2014-01-26T16:33:43.312085+02:00 foobar kernel: [11321361.444181] e1000 0000:00:03.0 eth0: Reset adapter
2014-01-26T16:33:43.504585+02:00 foobar kernel: [11321361.636903] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX

Just before those 3 successful resets I got a watchdog warning: http://pastebin.com/raw.php?i=Q1vXE5mn

Some more info about the system:

# lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)

# ethtool -i eth0
driver: e1000
version: 7.3.21-k8-NAPI
bus-info: 0000:00:03.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no

I cannot find anything else in the logs that relate to this issue. Any idea why this has happened or where should I look at next?


Had a similar problem after upgrading to 4.3.22 this morning. Quick fix was to shut down my VM's and change the network adapter types to something that wasn't Intel.

Been running a couple of hours now with no issues.

| improve this answer | |
  • 1
    Changing from Intel to another adapter worked for me too – Ben Ziegler Feb 22 '15 at 16:47
  • 1
    Since this shows up quite early in the Google results I would like to share my solution for a CentOS 7 Guest on a Fedora 26 Host with VirtualBox 5.2.0. Do not install the VirtualBox Guest Additions. See the related bug report for more information / details: virtualbox.org/ticket/15845#comment:4 – Alex Nov 20 '17 at 17:28
  • I tried this, but have no internet connection when I use anything other than Intel PRO/1000 MT Desktop (82540EM) – Shadoninja Jun 1 at 16:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.