I have a Windows Server SBS 2011 Box that is having some strange issues related to the Windows Server Service Provider Registry. A number of windows server services were running into issues starting and I traced it back to this service. It's dependencies are started and running without errors that I can see.

This is the error I get when I try to start the service:

Error 1067: The process terminated unexpectedly.

The event viewer errors are listed below (2)


And a .Net Error:

Source: .Net Runtime
Event ID: 1025

Application: ProviderRegistryService.exe
Framework Version: v4.0.30319
Description: The application requested process termination through System.Environment.FailFast(string message).
Message: Unhandled exception in OnStart: System.InvalidOperationException: Service ServiceRegistryProvider was not found on computer '.'. ---> System.ComponentModel.Win32Exception: The specified service does not exist as an installed service
   --- End of inner exception stack trace ---
   at System.ServiceProcess.ServiceController.GenerateNames()
   at System.ServiceProcess.ServiceController.get_DisplayName()
   at Microsoft.WindowsServerSolutions.Common.ServiceUtility.GetDisplayName(String serviceName)
   at Microsoft.WindowsServerSolutions.Common.ProviderFramework.ProductConfigurator.LogServiceStartFailure(String serviceName, String info)
   at Microsoft.WindowsServerSolutions.Common.ProviderFramework.ProviderRegistry.ServiceShell.OpenHost()
   at Microsoft.WindowsServerSolutions.Common.Services.WssgServiceBase.OnStart(String[] args)
   at System.Environment.FailFast(System.String, System.Exception)
   at Microsoft.WindowsServerSolutions.Common.Services.WssgServiceBase.OnStart(System.String[])
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()

After some research I found some similar cases, 1 dealt with the port used by the service which I cannot seem to find listed anywhere, including the config file for the service.

I recently ran an SFC Scan on the file and on the whole server which returned no errors. What I am looking for is if I need to work on trying to reinstall the service or if it could be a .Net error etc. Any help would be appreciated.

1 Answer 1


I too had this issue, however, I found a TechNet thread that really helped me clue in on a fix for this. Basically, the problem was that somehow the servers identity certificate had gotten deleted from the certificate store and it needed to be regenerated. When the certificate is missing it causes the "Windows Server Service Provider Registry" service to fail which in turn causes a bunch of other dependent services to fail as well.

I'll re-post the same thing that I put in the TechNet thread below. Hopefully this helps someone!

I had this exact same problem! Thank you so much Robert for posting a link to that script! That is truly an amazing Powershell script.

I had all the same errors that AK772 mentioned, but I chose to zoom in on a different issue that the script pointed out. When I ran the "Test CA Infrastructure" step it found several errors. When I looked at what the script was doing there it was comparing the server certificate thumbprint in the registry (HKLM:\Software\Microsoft\Windows Server\Identity) with the personal certificates (Personal Certificates in the Certificate snap-in using MMC). When I looked through them individually, sure enough the thumbprint in the registry didn't exist in my certificate store. I have NO idea how this could have happened!

However, from there, I changed my Google search criteria and found the following excellent article: http://titlerequired.com/2013/04/29/windows-server-2012-essentials-an-error-prevented-the-dashboard-from-opening/

This told more about that error and showed how to regenerate the certificate identity in the registry. This totally saved me! Once I ran through the steps that he outlines, even though I got a timeout error towards the end, I could see that the certificate thumbprint had changed in the registry and now existed in my personal certificate store.

Once I saw this, I tried going into services and manually starting the stopped "Windows Server Service Provider Registry" service. Sure enough it started right up, no error this time. Finally, I restarted the server so that all of the other dependent services would come back up and re-ran the linked script above and everything was perfect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .