1

I have a single exchange server 2013 standard. Exchange and it's database are installed on a single partition (i have 2 partitions, the other one is system).

I have been doing multiple imports via new-import request, and today i ran out of space on the database partition. i have increased partition size, but started getting "Failed to communicate with the mailbox database" error when i try to do anything with imports, exports, and a few other commands.

I was unable to stop, remove or view statistics on import requests. i dismounted the database, and that allowed me to remove all requests, but i am still unable to do anything regarding imports and exports.

Here is an example: [PS] C:\Windows\system32>New-MailboxImportRequest -Mailbox vsmaj -FilePath \206.156.102.185\mail\VSMAJLAG.PST -v

VERBOSE: [20:59:37.673 GMT] New-MailboxImportRequest : Active Directory session settings for 'New-MailboxImportRequest' are: View Entire Forest: 'False', Default Scope: 'excel-assemblies.com', Configuration Domain Controller: 'WIN2012DC.excel-assemblies.com', Preferred Global Catalog: 'WIN2012DC.excel-assemblies.com', Preferred Domain Controllers: '{ WIN2012DC.excel-assemblies.com }'

VERBOSE: [20:59:37.767 GMT] New-MailboxImportRequest : Runspace context: Executing user: excel-assemblies.com/Users/Administrator, Executing user organization: , Current organization: , RBAC-enabled: Enabled.

VERBOSE: [20:59:37.767 GMT] New-MailboxImportRequest : Beginning processing

VERBOSE: [20:59:37.782 GMT] New-MailboxImportRequest : Instantiating handler with index 0 for cmdlet extension agent "Admin Audit Log Agent".

VERBOSE: [20:59:37.782 GMT] New-MailboxImportRequest : Current ScopeSet is: { Recipient Read Scope: {{, }}, Recipient Write Scopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient Scope(s): {}, Exclusive Configuration Scope(s): {} }

VERBOSE: [20:59:37.782 GMT] New-MailboxImportRequest : The current object has been processed by the cmdlet extension agent with index 0.

VERBOSE: [20:59:37.782 GMT] New-MailboxImportRequest : Searching objects "vsmaj" of type "ADUser" under the root "$null".

VERBOSE: [20:59:37.860 GMT] New-MailboxImportRequest : Previous operation run on domain controller 'WIN2012DC.excel-assemblies.com'.

VERBOSE: [20:59:37.860 GMT] New-MailboxImportRequest : Searching objects "Mailbox Database 0886186604" of type "MailboxDatabase" under the root "$null".

VERBOSE: [20:59:37.860 GMT] New-MailboxImportRequest : Previous operation run on domain controller 'WIN2012DC.excel-assemblies.com'.

VERBOSE: [20:59:37.954 GMT] New-MailboxImportRequest : Admin Audit Log: Entered Handler:OnComplete.

THIS PART IS RED

Failed to communicate with the mailbox database.

  • CategoryInfo: ResourceUnavailable: (:) [New-MailboxImportRequest], StorageTransientException

  • FullyQualifiedErrorId: 6CBA0560,Microsoft.Exchange.Management.RecipientTasks.NewMailboxImportRequest

  • PSComputerName: mail.excel-assemblies.com

UP TO HERE

VERBOSE: [20:59:37.954 GMT] New-MailboxImportRequest : Ending processing [PS] C:\Windows\system32>

Anyone have any ideas what to do?

  • are you missing a "\" in front of the filepath for the PST? Also, you might want to move the file to a local store and try it. I know that doesn't address the mailbox database communications issue, but it might be referring to the source and not the destination. – MikeAWood Feb 14 '14 at 21:24
  • the command is fine, it just lost one \ during formatting. If i click on edit i can see it, so i guess it's a html problem. It's the same command i used to import before i ran out of space. tried it on a local file as well but same thing :(currently have 40GB of free space on the server. – darthzejdr Feb 14 '14 at 21:27
  • do you have more than one database? If so are you able to do mailbox moves between databases? Maybe your database file is corrupted somehow? Try creating a new mail database and see if it will import into the 2nd database – MikeAWood Feb 14 '14 at 21:29
  • Move mailbox to another database appears to work. Also if i create a new user in the old database i can't import into it. If i create it in a new database import works. I'm guessing i have a problem with the database. Is there any way to clean, or completely move the database to a new file? and would that take long(i have 500gb of emails in it). – darthzejdr Feb 14 '14 at 21:44
  • In your case if it was me, I'd make a new database and move everyone over. In fact, I would split all that mail into much smaller databases and not put all your eggs in one basket. In my case, I have about 900GB of email for ~150 mailboxes. We have 7 mail databases and 7 archive databases. I try to keep the active mail databases around the 30GB mark and that seems to limit my exposure. Just food for thought. But I'd agree, I think your mail database is hosed. – MikeAWood Feb 14 '14 at 21:51
0

As discussed in the comments section (and I shouldn't have done that), your problem is likely due to a corrupt mail database file in Exchange. In practice, limiting the size of the database files limits the number of mailboxes effected when one of the database files gets corrupted. In your case it was due to a lack of available drive space during a New-MailboxImportRequest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.