1

Ubuntu 12.04 LTS

Apache/2.2.22

http://server/lightsquid/ gives window with username/password request, then «500 Internal Server Error». Error rises whatever username and password were used: valid or not. If line Require valid-user is removed, everything works fine, so problem is in mod_authnz_ldap module.

Module mod_authnz_ldap is enabled. Apache config:

Alias           /lightsquid /usr/lib/cgi-bin/lightsquid
<Directory "/usr/lib/cgi-bin/lightsquid">
        AddHandler cgi-script .cgi
        Options +ExecCGI
        Order allow,deny
        Allow from all

        AuthType Basic
        AuthName "USE YOUR WINDOWS ACCOUNT"
        AuthBasicProvider ldap
        AuthzLDAPAuthoritative on
        #AuthzLDAPAuthoritative off
        #AuthUserFile /dev/null

        AuthLDAPBindDN "CN=squid_auth,DC=domain,DC=ru"
        AuthLDAPBindPassword "*****************"
        AuthLDAPURL "ldap://dc2.domain.ru/dc=domain,dc=ru?sAMAccountName?sub?(objectClass=*)"
        Require valid-user

</Directory>

Changing AuthzLDAPAuthoritative off to

AuthzLDAPAuthoritative 
AuthUserFile /dev/null

does not help.

LogLevel is debug.

error.log does not have any entries ablut error. In access.log I can see

192.168.0.1 - selivanov [15/Feb/2014:11:51:00 +0400] "GET /lightsquid/index.cgi HTTP/1.1" 500 814 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0"

How can I force it to give me normal problem diagnostics? Logs are almost empty.

  • 2
    Are you sure that you've restarted Apache since setting LogLevel debug, and that you're looking in the right error file? The first thing to do in a case like this is always to look in the error log, which must have some information in it. – Andrew Schulman Feb 15 '14 at 11:22
  • Yes, I restarted it. – Selivanov Pavel Feb 15 '14 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.