1

I've got a new dedicated leaseweb server with WHM/Cpanel. There's only 1 IP. I've registered the main domain iworldcreation.com at whois.com. It has two private nameservers assigned: ns1.iworldcreation.com and ns2.iworldcreation.com.

I also added two child name servers: ns1.iworldcreation.com pointing to 95.211.9.24 ns2.iworldcreation.com also pointing to the same IP 95.211.9.24

I know two ns'es pointing to the same IP is nonsense, but still that's how I configured the domain @ whois.com.

On WHM I've setup BIND and added zones, but I still get errors like: Missing nameservers reported by your nameservers when I check the nameserver setup via intodns.

Can someone advise where the problem is and what I need to do to fix it?

1 Answer 1

1

Did you read the rest of the output from intodns?

ERROR: One or more of your nameservers did not respond:
The ones that did not respond are:
95.211.9.24

Try starting the DNS server and making sure it isn't firewalled or misconfigured.

Your nameserver is having some sort of problem:

$ host -t ns iworldcreation.com. 95.211.9.24
Using domain server:
Name: 95.211.9.24
Address: 95.211.9.24#53
Aliases: 

Host iworldcreation.com not found: 2(SERVFAIL)

So you should check your logs and fix that.

And you're really going to need more than one nameserver here if you intend for this to be a serious web host, but you seem to know that already.

5
  • Yes, I read the whole output from intodns. But isn't it strange that I am able to successfully do nslookup queries on 95.211.9.24? Somehow I do get IP's back from my domains from the DNS on 95.211.9.24.
    – Mike
    Feb 16, 2014 at 17:05
  • Maybe you do, but nobody else does! See edit. Feb 16, 2014 at 17:08
  • I think I've fixed it. Can you please check for me?
    – Mike
    Feb 17, 2014 at 0:16
  • Seems to be working now. Feb 17, 2014 at 0:19
  • 1
    One last thing, if your problem is solved, be sure to mark it as solved by clicking the check mark. Welcome to Server Fault! Feb 17, 2014 at 0:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .