In an attempt to improve the security of my Windows Server 2008 R2 with Exchange 2010 SP3, I decided to test if File and Printer Sharing was really important to allow Exchange to work (thats all I really need from this server).

When I did, I ruined the server. Reenabling it don't seem to undo the mess.

After a reboot, Windows Explorer refuses to initialize. I'm limited to commands, some parts of Control Panel hang when I try to access them. I rebooted the server again, and now it doesn't even go past "Applying computer settings..."

I have no idea what to do, Google doesn't seem to help. Is it possible that I'm the only animal who ever tried to disable File and Printer Sharing in a domain controller?

How can I recover from this situation?

Note: I can access the shared folders from other network computers.

  • 1
    Backup? You DO have made one, or? It is like basline since - hm - 1955 or so ;) – TomTom Feb 16 '14 at 16:17
  • 2
    Sorry, you say you have Exchange problems but also mention domain controllers. Is your Exchange server also a DC? – MDMarra Feb 16 '14 at 20:31
  • 1
    That's really bad practice. You should migrate away from this ASAP. – MDMarra Feb 17 '14 at 3:30
  • 1
    file and printer sharing is not necessary to exchange and removing them should not have the slightest effect on whether or not windows boots. Removing or adding roles is a standard function and something which is done constantly on servers. Can you give an idea of what other modifications you made to the system? – Ian Murphy Feb 17 '14 at 12:53
  • 1
    One thing worth mentioning is that windows comes with its own backup software which works extremely well. Its also essential to backup an exchange server as exchange has a transactional log, like sql servers, which is only purged after doing a backup. – Ian Murphy Feb 17 '14 at 12:55

It's hard to say for certain based on the information you've provided, but I doubt that disabling and enabling file and print killed your server. I think it's far more likely that the server already had issues (bad hard drive?) and the reboots finished it off.

Your hardware vendor probably has diagnostics that will enable you to check the hard drives/RAID. That should be the first place you look. Correct any errors there before proceeding further.

Since you said in the comments above that your backups are ancient (ouch), assuming your storage tests clean and/or the RAID is repaired, you're probably going to have to attempt a repair install of Windows and hope for the best. (If it's a single disk, well. Ouch.)

Once you get your server back up, please implement a backup strategy. Do it for your future self, because hardware fails and there will be a next time.


I tried a "Boot with last valid configuration" and to my surprise it fixed the problem. I know this option is mostly useless with Domain Controllers, because it won't recover configuration of the Active Directory metadata, but aparently I got lucky with this one.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.