1

I am trying to allow people from outside of our organization to properly watch one of the Room Calendars.

I managed to successfully publish it using this powershell command:

Set-MailboxCalendarFolder -Identity mailbox-alias:\calendar -PublishEnabled $true  (replace mailbox-alias as your user's alias)

I then got the URL through this command:

Get-MailboxCalendarFolder -Identity mailbox-alias:\calendar (use the information from PublishedCalendarUrl as the publish URL address)

The Calendar is visible although I can see everything as "Busy" without actual information.

I then created a new Sharing Policy and applied it to the Room Calendar:

enter image description here

enter image description here

But that just doesnt work. Everything still is "Busy".

Could this be a permission thing?

enter image description here

Also made sure the policy was setup as CalendarSharingFreeBusyReviewer

enter image description here

But from the looks of it, the DetailLevel is just wrong:

enter image description here

Why is this "Availability Only"?

Also when I try to alter it I get a "Policy does not allow anonymous sharing"...

3 Answers 3

3

Run this command, it will expand what anonymous users are allowed to see:

Set-SharingPolicy -Identity "Enable Calendar Sharing" -Domains "*:CalendarSharingFreeBusyReviewer"

then

Set-Mailbox -Identity mailbox-alias -SharingPolicy "Enable Calendar Sharing"

You can check whether the right policy is assigned by running:

Get-Mailbox mailbox-alias | select SharingPolicy

If you are sharing with users who do not authenticate against your domains(ie, anyone else on the internet) set the correct permissions for the calendar

Set-MailboxFolderPermission mailbox-alias:\calendar -User Anonymous -AccessRights reviewer
Set-MailboxCalendarFolder -Identity mailbox-alias:\calendar -DetailLevel limitedDetails
6
  • I already did. I made sure that policy is enforced but everything remains "busy". I do believe the problem is with the "detaillevel : availabilityonly" when I check get-mailboxcalendarfolder -identity server-dev\calendar. However, attempting to change that throws out a "policy does not allow anonymous sharing".
    – JustAGuy
    Commented Feb 20, 2014 at 15:06
  • Edited the answer, hope it helps
    – Raf
    Commented Feb 20, 2014 at 15:16
  • Still no cigar I'm afraid :-\
    – JustAGuy
    Commented Feb 20, 2014 at 15:32
  • I added another command, that should do the trick!
    – Raf
    Commented Feb 20, 2014 at 15:43
  • As I mentioned earlier, I get a "Policy does not allow Anonymous sharing" on this one. Not really sure why as I have everything else setup as mentioned above.
    – JustAGuy
    Commented Feb 20, 2014 at 16:23
0
Set-MailboxCalendarFolder -Identity User:\Calendar -DetailLevel LimitedDetails
1
  • 1
    Welcome to Server Fault! It looks like you may have the knowledge to provide good Answer here, but please consider reading How do I write a good Answer? in our help center and then revise the Answer. Your Commands/Code/Settings may technically be the solution but some explanation is welcome. Thanks in advance. - Also please format commands/settings as code serverfault.com/editing-help
    – HBruijn
    Commented Nov 17, 2015 at 15:12
0

I just went into the O365 web portal, apparently the powershell comand isn't working, but you can just right click on the room name, and go to permissions, then change the sharing level there

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .