0

I'm trying to setup my Freenas server with Active Directory, it's connected fine and the following works:

[root@storage01] /# wbinfo -t
checking the trust secret for domain ISD via RPC calls succeeded

[root@storage01] /# wbinfo -g
*LIST OF GROUPS*

[root@storage01] /# wbinfo -u
*LIST OF USERS*

But when I setup a ZFS Dataset and try and setup the permissions to be one of our local active directory groups, no AD groups or users are in the dropdowns.

On top of this I seem to be getting this spammed a lot in the messages so I assume they might be linked:

eb 19 16:08:48 storage01 nmbd[65816]: Error - should be sent to WINS server
Feb 19 16:08:48 storage01 nmbd[65816]: [2014/02/19 16:08:48.242463, 0] nmbd/nmbd_incomingrequests.c:172(process_name_refresh_request)
Feb 19 16:08:48 storage01 nmbd[65816]: process_name_refresh_request: unicast name registration request received for name STORAGE01<03> from IP 10.44.15.152 on subnet UNICAST_SUBNET.
Feb 19 16:08:48 storage01 nmbd[65816]: [2014/02/19 16:08:48.242487, 0] nmbd/nmbd_incomingrequests.c:173(process_name_refresh_request)
Feb 19 16:08:48 storage01 nmbd[65816]: Error - should be sent to WINS server
Feb 19 16:08:48 storage01 nmbd[65816]: [2014/02/19 16:08:48.242530, 0] nmbd/nmbd_incomingrequests.c:172(process_name_refresh_request)

Any help will really be appreciated

0

Set the Rights Manually.

  • Click on "shell".
  • chown "domain.local\username":"domain.local\groupname" /mnt/VolName/Sharename
  • chmod 777 /mnt/VolName/Sharename

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.