1

I can ssh to my instance and use it but if I'm not active for some time then then I must reconnect. Is it the protocol, the server or the client that causes the timeout? It happens both with cygwin and putty on Windows 8.1 (but I didn't try between 2 Ubuntu).

4

If you are using cygwin ssh, you can add the following to your /home/user/.ssh/config file

Host *
  ServerAliveInterval 30
  ServerAliveCountMax 4

That should send an alive message to the server every 30 seconds and if it fails 4 times then the connection is closed.

0

If you are using Putty, there is a "Seconds between keepalives" setting on the Connection panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.