I have been searching all over for an answer, i got a cheap vps server running ubuntu 13.10 and installed webmin which should allow me to go to serverip:10000

But i can't connect to it and portcheckers such as yougetsignal.com says the port is closed.

i have tried running: iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 10000 -j ACCEPT

(and many other variations found on google, saving, restarting etc etc)

and when i run netstat -an | grep "LISTEN " i can see: tcp 0 0* LISTEN

ifconfig doesn't show any local ip, so it should be directly connected to the internet. there is no firewall installed, the "ufw" command is not recognized.

i have also flushed iptables and set input,output,forward to accept.

apparently the only port that is open is port 22, which i use to connect to it with ssh, even port 80 is closed.

(mainly i am trying to run another service on port 6121, same results, it's listening, but still blocked from connecting to it)

why are all these ports blocked? how can i open the ports and connect to/use my server?

EDIT> results of netstat -ntlp:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *               LISTEN      557/sendmail: MTA:
tcp        0      0 *               LISTEN      648/perl
tcp        0      0    *               LISTEN      610/apache2
tcp        0      0    *               LISTEN      425/sshd
tcp        0      0  *               LISTEN      557/sendmail: MTA:
tcp        0      0  *               LISTEN      4712/python
tcp6       0      0 :::22                   :::*                    LISTEN      425/sshd

result of iptables --list:

Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:6121
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:webmin

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

i got this reply from my host "We do not close or block any ports on our end. Make sure you have iptables disabled."

  • 1. Would you mind editing your answer to have the copy/pasted output of netstat -ntlp and iptables --list? 2. Can you curl localhost:10000 successfully? Have you contacted your VPS provider and/or read their docs to ensure that you're supposed to be able to use those ports? – Thanatos Feb 23 '14 at 3:52
  • added a paste of the results, curl is not installed. (command not found) – Robin Feb 23 '14 at 10:28
  • apt-get install curl – Adrian Perez Feb 23 '14 at 10:37
  • alright, installed curl, i get this result when running "curl localhost:10000" <h1>Error - Bad Request</h1> <pre>This web server is running in SSL mode. Try the URL <a href='localhost.localdomain:10000/'>https://…> instead.<br></pre> – Robin Feb 23 '14 at 11:27
  • Best thing is to contact your provider and check with them .. seems that they are denying the ports – sikas Jan 1 '15 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.