we run homogenous network based on Windows SBS (2008R2) server and W7 as clients. Today, the network start to act weird. From some of the computers (it seems that only from those who have been turned off during weekend) the speed of download from server shared drive is ridiculous, some 100-200kb/s on 1Gb network. From other computers the speed is just fine. What makes me crazy is the fact, that when I connect from the "slow" computer to the server via Remote desktop, and I simply COPY-PASTE the very same files to local computer, it runs with full speed (it means the physical connection between server and client is just fine and able to run on full speed, there is just some difference between copying from shared folder and via remote desktop) ! Ping behaves normally, all below 1ms, no timeouts, no lost packets.

All the clients and the server are 1Gb cable connected to Cisco SG-200 switch, no extra settings there. Only IPv4 is used, DNS and DHCP provided by Windows. Browsing on web on "slow" computers run on full speed as well, only shared drives and some applications from our server (photo map tiles) run slow.

I tried all I can, reseting network settings, setting various duplex mode on network cards, copy-paste various files, restarting services on server, disable and even uninstall antivirus, firewall, monitor on server and on client, that the network is not utilised (both run below 1%), the disks are not utilised (same ), CPU is just fine, so there are no visible problems on both sides, and as I mentioned, there are computers which can access the server with full speed, without anything being different.

Do you have ANY hints or ideas, how to troubleshoot it or what might be going wrong in this ?

Thank you

  • one thing that helped on one computer (but so far not on any other) was to disable signing SMB communication as mentioned here support.exinda.com/topic/… – Radek Feb 25 '14 at 11:36
  • 1
    Connect different computer in place of server and create test share. Then check the speed to the client. I had similar situation when i was biulding 1gb netowrk - we were clamping all cables by ourself. After all it came out that one pin in rj45 was badly clamped, and the result was exacly which you are describing - transfers about few hundreds kilobytes per socond on 1gb network. Just in case - check the cables. – integratorIT Feb 20 '15 at 10:50

I have an issue like this, the resource availability of my server was consummed by kaspersky reviewing every file on NAS/File system, after that all client previously authenticathed not lose access or performance to shared, but new clients without previous connection not able to view, transfer and the performance to connect to NAS File server was pooor.

So reviewing with the cmd "Net sessions", this list all active sessions consumed by file share access, multiple of that was made a month ago, plus Kaspersky reviewing and Search Indexer process duplicate the job of every read/write file the performance was degraded to 10%.

So, please review the connections, close the old connections, stop process using/examining files and test it with a recent power on computer.

Maybe you will need reboot the File Resource Service to acomplish this performance recovered to 100%.

Best regards!


I had a similar issue a few times ago, and the cause was the Task Offload feature from Microsoft TCP/IP transport Layer.

On Clients side, try (from an elevated command prompt) :

netsh interface ipv4 set global taskoffload=disabled

(Maybe you will have to reboot the client computer after that, i cannot remember).

  • 1
    thank you, but this didnt help, I just tried ... it must be something wrong with the windows shares and cable connection, when I connect via wifi to the hotspot plugged to very same switch as the other PCs, the speed is OK, as expected. – Radek Feb 25 '14 at 8:06

If you run a tracert does the traffic take a path you expect it to take?



The tracert should also show you where the slow hop is


We had a similar issue. But when we restarted the file server it persisted and we also noticed Outlook slowness. In our case it turned out to be a fibre connection between the workstation subnets and server subnets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.