3

I upgraded my ESXi 5.1 U1 to ESXi 5.1 U2 using SSH, after upgrade complete and I restart the server I couldn't connect to the Server using vSphere Client but I could connect to it using SSH after few Hours also the SSH stop working but all of my VMs work correctly.

I Tried to restart the server but the situation repeat I'm unable to connect using vSphere Client and Just for few Hours I can use SSH.

Because the server located in a data center I have limited access to my Server Screen and Keyboard (it is possible but have cost).

Part of vmkernel.log is:

2014-02-24T23:45:01.296Z cpu5:521314)ALERT: hostd detected to be non-responsive
2014-02-24T23:50:01.297Z cpu1:521473)WARNING: Tcpip: 1304: socreate(type=2, proto=0) failed with error No buffer space available (55)
2014-02-24T23:52:07.996Z cpu2:519491)WARNING: LinScsi: SCSILinuxQueueCommand:1193:queuecommand failed with status = 0x1056 Unknown status 
vmhba33:0:0:0 (driver name: ahci) - Message repeated 2194 times
2014-02-24T23:52:09.421Z cpu0:6262)ScsiDeviceIO: 2318: Cmd(0x4124007a2140) 0x2a, CmdSN 0x800000e4 from world 6549 to dev "t10.ATA_____TOSH
IBA_DT01ACA300_________________________________33815YEAS" failed H:0x0 D:0x8 P:0x0 Possible sense data: 0x0 0x0 0x0.
1
  • The SSH error message is: "ssh_exchange_identification: read: Connection reset by peer" Feb 24, 2014 at 23:16

3 Answers 3

2

Windows XP not supported by vSphere Client >5.1U1

I had the very same issue. The log file on ESXi stated that the cliend closed the connection.

After upgrading to ESXi 5.5 I obviously had to install the new client as well. During installation there was an notice that there might be a problem connecting to ESX server due to the operating system (Windows XP SP 3). In fact, I could not connect to my ESXi 5.5 with the exact same error message.

So I set up an Windows 8.1 box and installed the vSphere Client 5.5 there and could successfully connect to my ESXi 5.5U1 (build 1746018).

Note: if you cannot update your client OS to something above XP you might consider the following workarounds:

  • Use remote CLI commands to manage your VMs on the given host
  • downgrade to ESXi 5.1U1 with the following command:
esxcli software profile install -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-5.1.0-20131004001-standard --ok-to-remove

(This command is issued on the ESXi console. It can also be run remotely using something like "esxcli.exe -s vm.host.fqdn -u root ...". Be aware that the ESXi firewall must allow httpClient connections or use a local repository. For more information see e.g. @v-front

4

I suspect that you have an issue with your ESXi host's local storage. Where are the VMs located? On shared storage? On a different array controller than the ESXi installation?

Either way, the SSH identification errors in this case may indicate that the host is unable to read from disk. Remember that the networking stack and SSH daemon are running in RAM. Considering this is a hosted server, chances are that the equipment is low-end and you're suffering a storage problem.

Deal with someone who can evaluate the health of the hardware on premises.

Edit:

Your own update illustrates a problem with your 3TB consumer SATA drive, TOSHIBA_DT01ACA300 or the disk controller it's attached to. This is a hardware issue.

5
  • I have 3 HDD on the servers Most of my VMs and ESXi installation partition are located on the first HDD and currently I use other HDDs to store backups. Feb 24, 2014 at 23:30
  • No RAID? What make/model of server, disks and controller are in use?
    – ewwhite
    Feb 24, 2014 at 23:34
  • I also use ESXi Console (Yellow page) to restart Management Agent Services (Troubleshooting Menu) and now the SSH works normaly but vSphere Client cannot connect to the server. The error message is: "vSphere Client could not connect to xxx.xxx.xxx.xxx: An unknown connection error occured. (the client could not send a coplete request to the server.(The underlying connection was closed: An unexpected error occured on a send.))" Feb 24, 2014 at 23:34
  • It is custom build server from Hetzner. I checked the HDDs using ESXi disk utility S.M.A.R.T viewer, all hard disks are healthy. As I mentioned the problem starts after upgrading the ESXi installation to U2 Feb 24, 2014 at 23:38
  • @ImanGh If the disk is healthy, you want to look at the cables and the controller. Feb 25, 2014 at 1:13
1

You should be able to restart the management agents with /sbin/services.sh restart from an ssh session.

I have no idea why your ssh would stop working after a few hours.

4
  • I ran this command but I cannot connect to server using vSphere Client Feb 24, 2014 at 23:27
  • Did you upgrade your vsphere client after the 5.1 u2 upgrade? Feb 25, 2014 at 0:15
  • Yes I upgrade the vSphere client too. Feb 25, 2014 at 6:09
  • 1
    What's an "lspci -v" show you? Hetzner acknowledges that their server components are not on the HCL, doesn't mention 5.1U2 at all, and there was an update to the sata-ahci driver in that release. Feb 25, 2014 at 7:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .