0

I'm setting up a server but I can't get FTP to work properly. I use CentOS with vsftpd as ftp server. I'm working on a virtual server and there seems to be an error with the routing. When trying to log with FileZilla, this shows up and the connection fails :

227 Entering Passive Mode (192,168,1,21,102,251)

192.168.1.21 is wrong, it should stick to the server IP but how can I route it properly ?

Edit I : iptables is off on the virtual server

Edit II : I added the pasv_min_port/pasv_max_port to vsftpd.conf and it works for retrieving files list and open them... But I still can't upload anything

Edit III : file transfer works fine when I force the rights permissions to 777 but it's clearly not a permanent solution

1
  • What is the IP of the client you're connecting from? – Jenny D Feb 28 '14 at 10:34
0

Use the pasv_address vsftpd option to set the IP address that you want the server to advertise for passive data connections.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.