One of my vista sp2 clients can no longer see the default share on my sbs 2008 sp2 box.

The server has no av and i've unsintalled anti virus stuff from the client and rebooted it. The client was fine until today. I don't think anything has changed since it was working on Friday.

I've tried to access the share as the user that first reported the problem and as the domain admin. Both users can see all the other computers/shares on the network but can't get to the default share on the server. All the shares for the server (eg public and users) are listed when you browse it from the network and all work except the main one.

Clicking on the main share causes it to hang for a while and then either report it offline or access denied. Occasioanlly only printers and the one share that doesn't work are listed and the others aren't. It generally takes a long time before anything is listed.

It isn't a permissions things since i have changed the permissions to everyone with no effect.

What's weird is that it occasionally works fine for a few mins and then seems to cut out.

Other networking is fine (email,rdp) and no other clients have the issue.

edit ----

Seems to be spreading. on some other vista machines I'm getting related issues like not able to connect to mapped drives to this share at login and log login times.

Only vista clients?

I had a similar problem before which effected all clients (osx, xp, vista) and turned out to be the symantec av on the server which i have uninstalled. This is subtly different.

Why can't it just work! I'm not doing anything complicated!

2 Answers 2


Make sure the time/date on the Vista machine matches the server. Make sure the DNS server entry on the Vista machine's network properties point to only the SBS server

  • the dns is set to the server and the date/time is the same. Commented Aug 25, 2009 at 8:57

I disabled all tcp offloading on the server both in windows and on the NIC. I also disabled Receive Side Scaling and tcp tuning and rebooted the server and it seems to have solved it. the commands i ran were

netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled
netsh interface tcp set global chimney=disabled

Looking around this seems to be a problem with win2003sp2 but it seems to effect my sbs 2008 too. This is related to an earlier server fault post i made:

slow unc resolution on a win 2008 share

which i had tracked down to the A/V. It seems it's the A/V and the all the neworking stuff above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .