3

This post is a last-ditch effort for ideas.

Windows Server 2012 64-bit. Dedicated hardware.

On reboot, the pre-login screen reports failed patches and attempts recovery. When I log in, the explorer.exe files are missing and I only have a windowed command prompt. Server services appear to be working (SQL, etc). It's acting like it turned itself into Server Core.

  • There is no 'last known good' configuration.
  • There is no restore point.
  • sfc /scannow returns "repair in progress, reboot and scan again".
  • DISM.exe /Online /Cleanup-image /Scanhealth reports no corruption
  • All DaRT tools report a failure to run.

I'd love to be able to repair the OS, get a GUI back to use tools, and/or rollback patches.

Edit Powershell files are also missing.

| improve this question | | | | |
  • For clarification, is EXPLORER.EXE quite literally not to be found on the HDD anywhere, or is the shell just not being launched? – Simon Catlin Mar 3 '14 at 16:04
  • explorer.exe is literally not on the HDD. Edited question to clarify that. – schroeder Mar 3 '14 at 16:06
  • Are you running bitdefender? I just saw that problem on an ESXI-5.5 VM running bitdefender but the second time I clicked on explorer it ran fine even though I took no actions to correct the problem. – kkron Aug 11 '16 at 23:23
1

At the command prompt, start the system configuration tool (sconfig) and check if you haven't switched the server to "core" mode. If so, you can re-enabled it.

Alternatively, you can start powershell and run:

Get-WindowsFeature Server*

You should have a feature named Server-Gui-Shell and another named Server-Gui-Mgmt-Infra

To install the GUI shell from the powershell prompt, you can use:

Install-WindowsFeature Server-Gui-Shell, Server-Gui-Mgmt-Infra

Warning If your GUI shell is listed as being installed (i.e. you're not running "core"), you might get the shell back by uninstalling it and then reinstallling it but chances are other parts of the system are toast. A much wiser choice at this point it to reinstall and restore a backup.

If the GUI shell is listed as installed, you can try to uninstall it with the following command:

`Uninstall-WindowsFeature Server-Gui-Shell, Server-Gui-Mgmt-Infra

And then reinstall.

Warning (bis) You will need to reboot for any of the install/uninstall command to take affect.

| improve this answer | | | | |
  • 1
    Powershell.exe is gone from both locations. – schroeder Mar 3 '14 at 16:31
  • Then your install is toast. Rebuild from backup – Stephane Mar 3 '14 at 16:55
1

This is a fairly old post, I know, but I had this problem and wanted to post my solution, just in case I need it later :)

I also had no explorerer.exe and no powershell.exe

  1. Login to another server on the network
  2. Open "Server Manager"
  3. From the dashboard, select "Add other servers to manage"
  4. Add the other server
  5. From the "All Servers" right-click on the server you just added, then select "add roles and features"
  6. Select "Features" and scroll through the list until you find "Windows PowerShell", check that.
  7. Click "Next" then click "Install". You'll probably need to restart the server after the install completes
  8. Once it's available again, login to the main server
  9. Run start powershell.exe from the command line
  10. Run Install-WindowsFeature Server-Gui-Shell, Server-Gui-Mgmt-Infra as per @Stepane 's solution
  11. Re-start after that
  12. Done!
| improve this answer | | | | |
  • I wish I could confirm this solution to be able to accept it, but I thank you for adding a solution that worked for you! In 2014, I seem to remember that a particular patch caused this problem on Server. I can't remember how I fixed it (likely reinstalled). – schroeder Jan 30 at 9:02
1

Have you tried using the System File Checker (SFC) and DISM Scan & Restore offline?

If you boot from Windows install disk into command line you can run these tests.

In the next example the OS is available on the D: drive from the installer. And E: is the Windows Installer CD/USB:

sfc /scannow /offwindir=D:\windows /offbootdir=D:\
DISM /Image:D:\ /Cleanup-Image /ScanHealth 
DISM /Image:D:\ /Cleanup-Image /RestoreHealth /Source:E:\sources\install.wim
| improve this answer | | | | |
0

My initial thought would be to simply place a copy of EXPLORER.EXE in %Windir%. However, the fact that it's missing in the first place concerns me. It begs the question "what else is missing?".

I think I'd then want to confirm that Windows still thinks it should be using explorer, by running:

reg query "HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon" /v "Shell"
| improve this answer | | | | |
  • Registry reports the shell as explorer.exe. I tried copying one from a sister server, but it didn't work. – schroeder Mar 3 '14 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.