I've been a Linux sysadmin and am new to Windows so I apologize for the n00b question. I have two groups lets call them "Students" and "Professors". Students are very restricted, however professors have access to some unique things. One of them is a P:\ drive. The drive is mapped as follows:

\\Server\Public -> P:\

All Professors have full read\write access to this. It is designed for them to share files with each other. Students do not have access to \\Server\ or \\Server\Public but I have a professor who wants to share files with some students.

The only workaround I came up with so far (which leaves everything as far as permissions\shares go as they are) is to create a "Shared" folder in his local profile and share it with EVERYONE, and give EVERYONE read-only access. Students can access it by going to "\\COMPUTER_NAME\Users\USER_NAME\Shared" (and that's all they can see).

The problem is the professor has to copy all the files to his local profile from the P drive. It's not too big of a deal but I want a more elegant solution. I tried creating a symlink in "Shared" as follows:

\\COMPUTER_NAME\Users\USER_NAME\Shared\linked_dir <-> \\Server\Public

but students still were unable to access it (I'm sure it is designed like that on purpose).

Any ideas?

  • Why the downvote? – asdffffff Mar 4 '14 at 17:03
  • Why are the students on the same AD Domain as the staff? – TheCleaner Mar 4 '14 at 19:07
  • That's just how it came. I work here, I didn't make it! They are separated and have different groups and GPOs. Why does it matter if they are in the same domain? – asdffffff Mar 4 '14 at 19:21
  • Most academic environments are better off putting students on their own AD domain and preferably own network entirely. This helps to prevent security issues and problems with staff being able to do their jobs properly. – TheCleaner Mar 4 '14 at 19:57

If a user has rights to a sub-directory on a share, I believe it is possible to directly map to it.

net use m: \\server\public\jprof\cs101\files 

You can't map M: (for example) directly to the share and navigate down, that's what messes some people up. To do that you'll have to get funky with permissions, and that's a lot of work.

  • I tried that and since students do not have access to \\server\Public that seems to mean they don't have to access to \\server\Public\shared_dir even when I gave EVERYONE full control – asdffffff Mar 4 '14 at 19:00
  • You have to set the SHARE level permissions for PUBLIC to "EVERYONE - FULL CONTROL" as well. – TheCleaner Mar 4 '14 at 19:06
  • There is no ability to change them. Properties on a standard (local) folder gives me the the sharing tab, but I do not have that tab on \\Server\Public\test_folder – asdffffff Mar 4 '14 at 19:13
  • Got it. I can share E:\Public\test_folder (\\Server\Public maps to E:\Public on the server) by setting this as an Admin but this creates \\Server\test_folder. This is ugly. I want them to go to \\Server\Public\test_folder even though they can't go to \\Server\Public – asdffffff Mar 4 '14 at 19:22
  • 1
    You have to set the permissions on the PUBLIC share, then give them access to whatever that subfolder (files) is. Then they can map directly to that subfolder (as in sysadmin's answer). Assuming bypass traverse checking is enabled (by default it is), it will work fine. – TheCleaner Mar 4 '14 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.