1

I am trying to get a copy of some files from a repository and am having an issue with the last command they have listed on the website. Here is the commands they gave me.

$ touch .cvspass
$ echo "/1 :pserver:coralcvs@opencoral.mit.edu:2401/usr/local/coral-repository Atth0 y'tt" >> .cvspass
$ cvs -d :pserver:coralcvs@opencoral.mit.edu:/usr/local/coral-repository checkout -r <tag> opencoral 

The issue I am having is with the part of the last command. I keep getting an error that says:

bash: tag: No such file or directory

I am probably doing something incorrectly but I have tried looking at guides on how to use CVS commands and I am still confused. Could someone offer some assistance?

Also, I am running Fedora 20.

  • Do you really want to use cvs? I would be tempted to use git-cvs to pull in the full repository. Then use git commands. – Zoredache Mar 4 '14 at 20:36
0

<tag> is not supposed to be taken literally, it is a placeholder. This should be pretty self-evident reading the first paragraph under Download Source from the CVS Repository of the instructions on downloading OpenCoral from CVS.

  • I tried replacing <tag> with coral-3_4_8. Could you please give an example? – user2363217 Mar 4 '14 at 20:25
  • coral-3_4_8 works fine for me. cvs -d :pserver:coralcvs@opencoral.mit.edu:/usr/local/coral-repository checkout -r coral-3_4_8 opencoral – yoonix Mar 4 '14 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.