0

I'm using an Amazon RDS with MySQL, and I connect to it via another EC2 machine. I correctly set the Security Groups; and it has been working good for two days. Today, for a test I scaled the RDS istance from db.t1.micro to db.m1.small. And it worked. Then I re-scaled down to db.t1.micro and rebooted the machine.

Now, I'm unable to connect. I have changed nothing on the EC2 machine, the hostname for RDS is the same, and the RDS is running. I also tried to reboot two more times the RDS, but nothing changed...

How come? It seems to be a problem in Amazon AWS...

  • 1
    Probably a better question to ask Amazon's tech support. – NickW Mar 5 '14 at 12:46
  • I tried again to connect, and now it seems working. I don't know why, but I got this problems with RDS twice, perhaps it needs a lot of time (several minutes) to reboot after scaling? – Carmine Giangregorio Mar 7 '14 at 20:59
0

It seems like your RDS instance got hosed. Do you have any snapshots where you can create another one from ? I performed the same operations that you described and my database works fine. You can also check the logs:

RDS Logs

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.