0

I’m trying to stand up a new SharePoint 2013 farm.

I've got an issue where we aren't syncing all of the user properties between sharepoint and AD, and it’s the email properties in particular that I’m after.

We’re using the AD import sync method instead of the full User Profile Service Sync. But I tried that anyway, and it’s made no difference. SharePoint was not installed withsingle server method, and I didn't let sharepoint auto config itself. I used the technet docs on doing the farm configs, so obviously I screwed something up.

I tried deleting and recreating the user profile service application, and it did nothing. I don’t see any problems in the UCS logs either, although I might just be missing it. There is no Exchange integration in this AD Domain, but the email attribute in AD is populated. Additionally, we've confirmed that the account I’m using for AD sync has the correct permissions for accessing AD.

My Sites is running a separate web application and user account then the general sharepoint content. In addition, we confirmed that the account used to sync with active directory has the correct AD permissions ... replicate directory changes, etc ...

Here's an screen shot of the user properties page after AD sync has been setup. As you can see, all properties are read only

1

The account being used to perform the import must have "Replicate Directory" permissions within Active Directory.

From Microsoft TechNet (http://technet.microsoft.com/en-us/library/jj219646(v=office.15).aspx) step 8d:

In the Account name box, type the synchronization account in the form \. The synchronization account must have Replicate Directory permissions or higher on the root OU of Active Directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.