1

I am trying to setup IIS 7.0 dispatcher module for CQ5 following the setup: http://dev.day.com/docs/en/cq/current/deploying/dispatcher/disp_install.html.

I am trying on windows 2008 sp2 64bit and a local publishing istance on port 4203.

The dispatcher works as long as cache is disabled, once I enable it, files are written in the document root but the homepage is returned empty and I get in my dispatcher.log:

[Fri Mar 07 16:38:24 2014] [D] [3180(2108)] checking [/content/geometrixx-outdoors/en.html]
[Fri Mar 07 16:38:24 2014] [D] [3180(2108)] never flushed [E:\wwwroot2\.stat] -> use cache [E:\wwwroot2\content\geometrixx-outdoors\en.html]
[Fri Mar 07 16:38:24 2014] [D] [3180(2108)] cache-action for [/content/geometrixx-outdoors/en.html]: SPOOL
[Fri Mar 07 16:38:24 2014] [D] [3180(2108)] request declined
[Fri Mar 07 16:38:24 2014] [I] [3180(2108)] "GET /content/geometrixx-outdoors/en.html" 0 - 0ms
[Fri Mar 07 16:38:24 2014] [W] [3180(2108)] HSE_REQ_EXEC_URL(/content/geometrixx-outdoors/en.html) returned: 000003E9

I get a code 200 from my IIS 7.0

I gave modify permission to IUSER and tried also a

icacls e:\wwwroot2 /grant "IIS APPPOOL\DefaultAppPool":(OI)(CI)(RX)

(should not be necessary since I am on 7.0 and not 7.5) The dispatcher is installed as handler mapping

if I bypass cache with a query string as in

http://myserver/content/geometrixx-outdoors/en.html?a=1

it works

any hint?

1

I have the similar issue, and I fixed it by setting the "required path" as * instead of *.* in window "Edit Script Map" in Handler Mappings.

0

I managed to find the answer on adobe forum:

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manager.topic.html/forum__arow-i_have_spentthepas.html#forum__arow-i_have_spentthepas__gmqe-from_error_seemslik

I was missing these steps:

Click back on the site. And Double-Click Configuration Editor. 
For Section dropdown list select system.webServer/handlers. For From select the Site. 
Click the Count= field and select the … button
Select CQ and change requireAccess to None. Close and click the Apply button (top/right corner).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.