I try to install ruby 2.1.1 by RVM and I receive following error:

vmamaev@vmamaev:~$ rvm install ruby-2.1.1
ruby-2.1.1 - #removing src.
Searching for binary rubies, this might take some time.
No binary rubies available for: debian/7/i386/ruby-2.1.1.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for debian.
Requirements installation successful.
Installing Ruby from source to: /home/vmamaev/.rvm/rubies/ruby-2.1.1, this may take a while depending on your cpu(s)...
ruby-2.1.1 - #downloading ruby-2.1.1, this may take a while depending on your connection...
ruby-2.1.1 - #extracting ruby-2.1.1 to /home/vmamaev/.rvm/src/ruby-2.1.1.
ruby-2.1.1 - #configuring.....................................................
ruby-2.1.1 - #post-configuration.
ruby-2.1.1 - #compiling..........
Error running '__rvm_make -j1',
showing last 15 lines of /home/vmamaev/.rvm/log/1394209466_ruby-2.1.1/make.log
compiling vm_trace.c
compiling thread.c
compiling cont.c
compiling ./enc/ascii.c
compiling ./enc/us_ascii.c
compiling ./enc/unicode.c
compiling ./enc/utf_8.c
compiling newline.c
compiling ./missing/strlcpy.c
compiling ./missing/strlcat.c
compiling ./missing/setproctitle.c
compiling addr2line.c
compiling dmyext.c
linking miniruby
make: *** [.rbconfig.time] Illegal instruction
There has been an error while running make. Halting the installation

vmamaev@vmamaev:~$ rvm requirements
Checking requirements for debian.
Requirements installation successful.

make.log file

PC settings:

  • AMD Athlon 2200 mhz

  • 32bit

  • 2GB RAM

  • Debian 7

  • gcc-4.7

plz help me to install ruby by rvm...

Previously I installed Arch Linux, and I received the same problem.

  • Try to run it again. Does it crash at the same point, or does it crash at a different point, or does it finish successfully? Mar 7, 2014 at 17:40
  • It crash at the same point (try 1 pastebin.com/yN8b8La3, try 2 pastebin.com/sFkE1Xve).
    – vmamaev
    Mar 7, 2014 at 18:23
  • 2.1.0 and 2.0.0 installed successfully!!! very strange...
    – vmamaev
    Mar 7, 2014 at 18:57
  • Then it might be a bug that you should report upstream. Mar 7, 2014 at 19:01

2 Answers 2


There is problem with CFLAGS="-march=native". Try to specify the standart flags for the compiler gcc.


Check this workaround, it worked for me: https://github.com/wayneeseguin/rvm/issues/2850


  • What is the workaround? Keep in mind that links die, and your answer cannot be considered complete if it is only a link to another site. May 14, 2014 at 22:48
  • @user219813, if you want to add a new answer, go ahead and add it as a new answer instead of editing this one. May 15, 2014 at 8:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .