0

Been trying for hours but just can't seem to get the correct syntax in my lighttpd configuration. As a last resort I am now asking the hive mind of server fault :P

I am trying to get trac hosted on the lighttpd server and keep php working at the same time. I include the config file "fastcgi.conf" which contains the following:

server.modules += ("mod_fastcgi")
index.file.names += ("index.php")

fastcgi.server = (
        ".php" = > ("localhost" = > (
                "bin-path" = > "/usr/bin/php-cgi",
                "socket" = > "/tmp/php-fastcgi.sock",
                "max-procs" = > 4, # default value
                "bin-environment" = > (
                        "PHP_FCGI_CHILDREN" = > "1", # default value
                        ),
                "broken-scriptfilename" = > "enable"
                )),
        "/trac" = >
        ("trac" = >
                ("socket" = > "/tmp/trac-fastcgi.sock",
                        "bin-path" = > fcgi_binary,
                        "check-local" = > "disable",
                        "bin-environment" = >
                        ("TRAC_ENV" = > "/mnt/external2/league-trac")
                        )
                )
        )

But i get the following error. I tried all examples and even directly copied some but still get errors. This is the error i get with above config file:

2014-03-09 12:48:44: (configfile.c.589) source: ../conf.d/fastcgi.conf line: 9 pos: 16 use => for assignments in arrays 2014-03-09 12:48:44: (configfile.c.954) configfile parser failed at: .php 2014-03-09 12:48:44: (configfile.c.957) source: ../lighttpd.conf line: 14 pos: 8 parser failed somehow near here: (EOL)

Can you guys help me out? I have no real experience with these kind of configs and just can't get it to work. Its probably something real simple and stupid.

1

= > is wrong, use => (no space between the two characters)

  • Thanks. Another fault was index.file.names which should be index-file.names. And fcgi_binary should have been replaced with the location of the fcgi binary in double quotes. But your answer made it possible to find the other 2 faults. – Boelensman1 Mar 14 '14 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.