I am trying to install an MSI on a Windows Server 2012 machine which is part of my lab domain. I am local and domain admin, but I seem to be prevented from installing this MSI.

For clarification, when attempting to install the git extension for visual studio (located here) logged in as a domain user that is part of the administrator group, I get the following error

enter image description here

The machine reporting the error is a Windows Server 2012.

I'm almost certain it must be some sort of group policy restriction? None will have been set, unless it's the default security level?

For clarification, I'd like to know what is preventing this MSI being installed by a domain admin?


7 Answers 7


After spending time looking at group policy, as far as I could tell, there was nothing that was relevant. I then came across this post that suggest I try launching a command promt as an administrator and running

 msiexec /a install.msi

This appeared to work, but ran very quickly - in fact it didn't. On a whim, I tried this inside the admin command prompt.

 msiexec /i install.msi

which worked a treat.

  • 1
    This works but it can be irritating to do every time you install from an msi. See Armin Sadeghi's answer below for a long-term solution.
    – Jake
    Sep 1, 2016 at 0:23
  • Not ideal if you need to install something as a user.
    – HippoDuck
    Aug 16, 2022 at 12:30

I've run into this behavior, where MSI installation is prevented with "The system administrator has set policies to prevent this installation" before. I believe it is due to default Windows Software Restriction policy and I've seen it on both Windows Server 2008 R2 and Windows Server 2012.

There is probably a better GUI based way to alter the policy, but setting the following reg key as an admin on the machine does the trick:

  • 6
    This works 100% Jul 23, 2015 at 0:57
  • 3
    This worked for me. I had to add the "Installer" part of the path as a key, then add the DWORD "DisableMSI" (without the quotes).
    – Mike S
    Apr 13, 2016 at 18:12
  • 1
    Had same error message with AcrobatReader update, after change registry to zero install was successful.
    – Kemin Zhou
    Feb 18, 2019 at 6:19
  • Tried looking for the "DisableMSI" key on the "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer" registry path, but the "Installer" folder does not exist. Should I create an Installer folder and add in the DisableMSI dword? Nov 18, 2019 at 8:53

This is usually due to a Group Policy or a Local Policy disabling Windows Installer.

Look on your Domain Controller if you have a GPO disabling "Windows Installer": Computer Configuration > Administrative Templates > Windows Components > Windows Installer > "Turn off Windows Installer".

Verify that it is set to "Not configured" or "Disabled".

If if you don't find it in your GPO's, look on the computer's local policies using gpedit.msc.

Note: the fact that you are a domain admins doesn't matter. It all depends of the scope of the GPO.

  • 6
    Verify that it is set to "Not configured" or "Disabled". That's not true. The default (Not Configured) is 1 which means managed only. msdn.microsoft.com/en-us/library/aa368304.aspx Disabled in terms of gpos means the policy will be disabled, so the reg key will be deleted and the default is used. Sound's strange but you have to choose Enabled and select Never in the dropdown box. Jul 17, 2017 at 7:26
  • @JürgenSteinblock's comment is what fixed it for me on Server 2019.
    – jeffmjack
    Jan 13, 2020 at 18:48

We had the same exact issue when building an MSI using IsCmdBld.exe, but not when building from the InstallShield software user interface.

When running the installer, we would see the error mentioned by the OP and the installation log would show: MSI_LUA: Invalid Descriptor Format.

The cause of the problem was that we were passing a ProductCode Guid value to the IsCmdBld.exe command line like this: -z "ProductCode"="f176c219-dec0-4fa9-a373-94a711f28a3d".

You can see that the Guid provided here is not surrounded by { and }.

We fixed it by passing the guid with brackets around: -z "ProductCode"="{f176c219-dec0-4fa9-a373-94a711f28a3d}" which works as expected and does not display the error anymore.


right-click -> run as administrator

  • 3
    How is this different than accepted answer?
    – Dave M
    Oct 26, 2015 at 19:15

Neither the msiexec nor registry fixes worked for me (even after rebooting), but disabling User Account Control (as suggested by Ha Ly in this thread) and rebooting did the trick.


You have the option to turn off UAC via registry by changing the DWORD EnableLUA from 1 to 0 in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system. You will get a notification that a reboot is required. After the reboot, UAC is disabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .