1

I'm trying a new install of XenServer 6.2 on an HP Proliant DL160G6 with a HP P410 raid card configured as RAID 5 over 4 drives, with a 256M BBWC. The install starts off properly, but when it gets to about 56% completion of "Installing from Base Pack", it just completely freezes and stops continuing. I am unable to switch consoles using Alt-F2, etc.

I've tried rebooting and restarting the install, but to no additional success.

If, however, I reconfigure my HW Raid as Raid 1 or Raid 1+0, the installation is successful, which makes me wonder if this is a compatibility issue with P410 Raid configuration, however, according to the HCL, the P410 is listed as compatible.

I've tried running Inquisitor as a stress test on the RAID, and it passes flawlessly in RAID-5 configuration.

How can I further diagnose where the problem lies? Is there a way to see exactly where/why this is failing? What would cause it to fail on Raid 5 but not Raid 1?

  • It could easily just be a volume size>2TB issue, can you create a 2TB volume off the R5 and try that, then create a 2.TB volumes and try that. Also that's not a supported OS/HW combination by the way. – Chopper3 Mar 10 '14 at 16:19
  • Sorry - I should have metionned it, but my RAID 5 is 4x500G drives, so effective logical RAID volume size is roughly 1.5T. I'm also not sure what you mean by not a supported OS/HW combination. The HCL seems to indicate that it is? – Eric B. Mar 10 '14 at 16:36
  • Ah ok, well ignore the >2TB thing, we have seen issues with that previously is all. As for support, take a look here; h18004.www1.hp.com/products/servers/software/citrix/… – Chopper3 Mar 10 '14 at 16:44
  • @Chopper3 I forgot about that; I had seen that page as well, but thought that it might have been an oversight. :) I don't understand why it installs under RAID 1 or RAID 1+0 without issues though. I tried installing 6.1 but have run into problems with 6.1 as well "ERROR: :An unrecoverable error has occurred: the decompressor died with signal 2 whilst processing package dom0fs.tar.bz2". So I wasn't much further ahead there either. – Eric B. Mar 10 '14 at 17:07
  • I agree it's very weird, the OS shouldn't be aware of the array configuration at all. To be honest I detest R5 anyway but that's your choice I guess - don't really know how to move this forward sorry. – Chopper3 Mar 10 '14 at 17:42
1

Please see the answer at: HP DL320e Gen8, 3TB drives, Windows Server 2012 R2 - HDD full capacity alocation difficulties during installation for general local disk and logical drive guidance. Perhaps there's a 1TB issue that you clear when using RAID 1+0, but not in RAID 5.

But your specific case here appears to be firmware related. The best course of action is to run the bootable Service Pack for ProLiant DVD.

Your RAID controller should be at revision 6.40. There's plenty in the change log that could be the root cause.

  • Thanks; I will take a look at that. I have finished downloading the Service Pack DVD (thanks so much for the link), and will try to install it tomorrow. I suspected it may be Raid firmware related, but couldn't find anything in the RAID BIOS configurator that indicated the FW version on the card. I will post updated information once I run the Service Pack. – Eric B. Mar 12 '14 at 0:53
  • I ran the SP and upgraded the P410 firmware and XenServer installs properly now. Thanks! – Eric B. Mar 12 '14 at 17:23
  • @EricB. Perfect! Glad to see it worked out. – ewwhite Mar 12 '14 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.