0

Goal

I am trying to setup a local DNS server here in our office.

Problem

Apparently Comcast has a loop-back so when we configured the domain to go to our IP it works outside of the office but inside it fails.

Actions taken

We decided to setup a local DNS server so that anyone requesting our domains inside will still be able to view them.

We have it setup for the most part but it just wont seem to work when we add the IP of the DNS server to the DNS settings in the router.

However, when I go into my local computer and add the IP there in the DNS settings it resolves correctly.

Request

There must be something that I am missing in the router configuration.

If you have any links with really good examples of how to setup one up that would be great.

We are using Red Hat but anything is helpful.

Thanks in advance.

  • Holy blob of text, batman. Care to insert a few CRLFs in there? – EEAA Mar 10 '14 at 22:29
  • @EEAA, you have the power to edit, my friend. – Vasili Syrakis Mar 10 '14 at 22:59
  • 1
    @vasilisyrakis Surely, I do. I also have the power to call out users that don't even bother to put a modicum of effort into formatting their question to make it legible. – EEAA Mar 10 '14 at 23:05
  • @EEAA thanks for the suggestion. Sorry i have been staring at this all day and part of the day on Friday and now im just a bit frustrated. No excuse but just letting you know where I am. Should be fixed now. – ngreenwood6 Mar 10 '14 at 23:27
  • Which Red Hat (Enterprise Linux): 4, 5, 6? – Cristian Ciupitu Mar 13 '14 at 12:11
0

How many computers do you have in office? When there is small one, simply use statical network setting and statical /etc/hosts resolving or C:\Windows\System32\drivers\etc\hosts for windows. This is easy. But when you have more computers, central configuration server will be better. Create DNS server but follow howtos. Your DNS should cache question to external (out of your office) addresses. Otherwise this will be unusable.

for example follow this help: https://www.digitalocean.com/community/articles/how-to-install-the-bind-dns-server-on-centos-6 or you can get help everywhere. use some web search service and type: bind setup howto .

after this configure your domains, straight (names) and reverse (ip's). try locally using nslookup what you get. this is ok or not. try internal and external names and addresses. This should improove your network, because most of dns requests will be resolved locally :)

when it's done, try configure manually some station and point dns property to your server. I hope this will work.

Last step. after that you can configre your own DHCP server. But remember "there can be only one", otherwise they will faith for workstations :P Other DHCP servers should be powered off. Look for "home" routers, switches etc on "local network' side. How to setup dncp? try url:

http://www.howtoforge.com/dhcp_server_linux_debian_sarge

on this ^^^^^ page you'll find much more :) remember for setting up ethernet device staticly. Otherwise server won't get his network configuration.

good luck.

0

You need to go into the DHCP settings of your router and set your server as the DNS server for the DHCP clients. To debug you should know how to view the info returned in the DHCP lease on a client.

Edit: The exact details depend on the model of your router. I'll take an example from DD-WRT, open source router firmware: DD-WRT DHCP web page. They are the settings Static DNS 1-3. You'll have to find the equivalent setting in your router's web pages.

The thing is, not every router offers the feature to set the DNS server in the DHCP lease. Some just pass along the DNS servers from the upstream connection. If your router doesn't have the feature you are out of luck. Either you have to get a router that does have this feature, or turn off the router's DHCP server and use a DHCP server elsewhere on the LAN, perhaps the same server as your DNS server. There are reliability ramifications for such a move.

  • Hello, welcome on serverfault. Can you please provide a more detailed answer? (use edit button) – user130370 Mar 12 '14 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.