I am tryig to set up pure-ftpd on an Ubuntu 12.04 and have it work with the pure-authd. I have created a user and group, gotten the authd daemon running. I also have a script ready to go that will work fine doing the custom auth for the daemon. However, I can't see how to get pure-ftpd to use the authd authentication method. I see that the config options are set in /etc/pure-ftpd/conf as individual files with the values as the values of the settings. I have searched extensively and have not found out how to get pure-ftpd to use authd instead of one of the other auth options. Could anyone point me to what flag or setting to use to get this to work?


Here is what I have done so far to get things much further than before

  • Created an ftp user and an ftp group

sudo useradd -s /bin/bash -M -G ftpupload ftpupload

  • Ensured the following files were in /etc/pure-ftpd/conf
    • CreateHomeDir - contents: "yes"
    • ExtAuth - contents: [the path to the auth script]
  • Made sure ftp user group could read/write to /var/run/pure-ftpd to enable it to make socket and pid file
  • Created symlink from /etc/pure-ftpd/conf/ExtAuth to /etc/pure-ftpd/auth/ExtAuth

sudo ln -s /etc/pure-ftpd/conf/ExtAuth /etc/pure-ftpd/auth/ExtAuth

  • Removed other symlinks in /etc/pure-ftpd/auth
  • Sample pure-authd call:

sudo pure-authd -p /var/run/pure-ftpd/pure-authd.pid -u 1012 -g 1013 -s /var/run/pure- ftpd/pure-ftpd.sock -r /usr/bin/auth_script.sh

  • Sample /etc/init.d/pure-ftpd restart call

sudo /etc/init.d/pure-ftpd restart

Restarting ftp server: Running: /usr/sbin/pure-ftpd -l extauth:/var/run/pure-ftpd/pure-ftpd.sock -j -d -p 30000:35000 -E -u 1000 -O clf:/var/log/pure-ftpd/transfer.log -8 UTF-8 -B

  • So, I did find a comment relating to debian setup of pure-ftpd with pure-authd on serverfault: link. I'll update my initial question with what I have done using that information.
    – imarsman
    Commented Mar 13, 2014 at 19:17

1 Answer 1


I believe the ExtAuth file in your conf dir is supposed to point to the socket, not the auth script (since pure-ftpd doesn't run the auth script directly, pure-authd does that, and they communicate through a socket)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .