2

I have a virtual network for connecting KVM guests with the host.

I need to disable TCP checksum offloading on this network. The ethtool works fine but I want to disable it permanently and I could not find anything in virsh or QEMU documentation. Adding /etc/sysconfig/network-scripts/ifcfg-virbr1 file with the corresponding options also does not work.

4
  • 1
    You want to disable offloading on a virtual network?! Mar 11, 2014 at 15:05
  • 1
    The client on the virtual guest is connecting to the server running on its virtual host. When the tx checksum offloading of the host virtual network is on the client receives packets with wrong checksum. When I turn off the offloading the problem disappears.
    – jackhab
    Mar 11, 2014 at 18:17
  • @jackhab Weird problem. How did you notice it? I'm just curious. Aug 17, 2016 at 6:31
  • @RyanBabchishin well, I noticed HTTP requests are stuck so I looked at the traffic in Wireshark.
    – jackhab
    Aug 17, 2016 at 17:40

2 Answers 2

3

ethtool -K eth0 tso off in rc.local or the vm startup script. You could probably do it as a libvirt hook too

2

I recommend doing this with a udev rule. I put this in /etc/udev/rules.d/81-bridge.rules:

ACTION=="add", SUBSYSTEM=="net", NAME=="virbr*", RUN+="/sbin/ethtool -K $env{INTERFACE} tx off"

More sophisticated approaches are possible, depending on your needs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.