0

I use a Motorola device with Windows CE 07.00.2806 and try to connect to a Windows Server 2008 R2 getting the following error message:

„An authentication error has occurred (Code: 0x80090304).“

Already checked the security settings on the server, rdp connections should have the right permissions. also tried different logins with / without domain and different users, all of them had admin priviledges on the server --> no success so far.

What am I missing?

I've read about a possible update fix on this site (FIX: "0x80090304" authentication error), but couldn't figure out how to update a windows ce device. Could this be the solution and how can I do this?

EDIT 1

server security settings

  • On the Windows Server, have you disabled the requirement for Network Level Authentication? – Chris McKeown Mar 11 '14 at 12:36
  • yes, see my updated question with the picture – tronc Mar 11 '14 at 12:46
  • You can download the latest monthly CE 7 updates from MS and then apply them directly to the CE device, is that your question? Because that KB article definitely looks like your issue and your fix. – TheCleaner Mar 11 '14 at 13:18
  • And how exactly can I do that? The downloadable exe file is not installable on the ce device, but opens a setup window on my windows 8 pc asking for a product key... – tronc Mar 11 '14 at 14:19
0

Problem was solved using a special update provided by the vendor of my device. To use the mentioned update from the KB article from Microsoft you have to use the CE image builder framework from Microsoft to build complete .iso-images for CE-devices. This was unneccessary and should be avoided as almost updates are provided by the device manufacturers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.