3

I am trying to install vlc to my lab of 150 window computers using puppet. I am following this guide and have set up my manifest as:

node 'node.domain.tld' {

package { "VLC media player 2.1.3":
 ensure   => "2.1.3",
 source   => "\\\\server\\puppet$\\vlc-2.1.3.exe",
 install_options => ['/L=1033 /S']
}

Running a puppet agent -t --debug shows that this command is being run:

cmd.exe /c start "puppet-install" /w \\server\puppet$\vlc-2.1.3.exe "/L=1033 /S"

This brings up the windows installer for VLC (but doesn't install silently) when puppet agent runs. When I run the command this way (without quotes), it installs silently as intended.

cmd.exe /c start "puppet-install" /w \\server\puppet$\vlc-2.1.3.exe /L=1033 /S

I came across this bug which appears to be resolved in version 3.3.0. Both the puppet master and agent in my environment are version 3.4.3.

Am I going about this the wrong way to install VLC?

2

I was told to change install_options => ['/L=1033 /S'] to install_options => ['/L=1033', '/S']

This appears to have solved the problem. Apparently I was sending both switches as one command instead of two separate commands.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.