1

volumeone.org


UPDATE

It's been more than 10 days now, and DNS changes still haven't been propagated for some people using AT&T (but since 4 days ago, it's showing up for at least one AT&T user that it wasn't before).


Updated DNS to point to a new IP address (switched a server within the same host).

People are seeing the new website almost everywhere, but several people are still not seeing the new site after 6 days. I am one of them. My home AT&T connection is not updated and at least one other person that reported this also uses AT&T.

I checked with the hosting company (softlayer) and they confirmed that the DNS settings are configured correctly. They said there's nothing I can do but change the TTL and wait.

OpenDNS also has not updated the IP address for their New York and Washington DC locations, according to this page. (sometimes it shows the correct IP addresses, sometimes it doesn't)

http://cachecheck.opendns.com/

I've never seen this before. Does anyone have any suggestions?

  • SOA version numbering was done correctly? It COULD be an idiotic configuration - it is not like there are no ISP's that are ignoring TTL and impose a much longer TTL on a zone to reduce traffic (with all kinds of side effects, but seriously 6 days would be quite extreme here). SOA version numbering issue would be my bet. – TomTom Mar 13 '14 at 16:03
  • Yes the SOA version number has been incrementing when I've updated it. (it's set to the the current hour YmdH) – Don Ross Mar 13 '14 at 16:20
  • 1
    You need to speak with however runs the DNS service you use. I have servers all over the world that aren't getting records returned. whatsmydns.net/#A/volumeone.org – Jacob Mar 17 '14 at 17:02
5

The nameservers appear to be somewhat less than optimally set up. Looking at the output from DNSCheck for volumeone.org, there are a few things that stand out.

  • The two name servers are both on the same AS. This means that if there is any problem reaching that AS, then neither of your nameservers will be accessible. It's generally recommended to have name server in at least two separate netblocks with separate routing, preferably in separate server halls, to avoid this.

  • SOA refresh and retry times are a bit low.

Apart from that, I can only suggest that you contact AT&T DNS admins. Possibly your hosting provider would be able to get in touch with them directly; I would assume that they're not easy for an end customer to get hold of.

  • I changed the SOA refresh time back to 1 day, and after about an hour all of these servers are connecting: whatsmydns.net/#A/volumeone.org There were several that weren't before. I don't know if that solved it for the AT&T users yet, but that's something that's working now, that hasn't been working for the past 10 days. (Note that I had tried refreshing the SOA version number several times before with no success. But it appears to have caused some DNS servers to recache this time.) – Don Ross Mar 17 '14 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.